PDA

View Full Version : [ubuntu] Nautilus window background goes black when using custom themes



yousufinternet
November 24th, 2014, 01:54 PM
I am facing a problem when using custom themes in ubuntu 14.04 64-bit unity interface, such as the mbuntu-y theme appearing in the screenshot attached, as you can see the background of nautilus window goes black sometimes when using custom themes, this does not happen when I use Ambiance or Radiance themes.. I have to switch the view to list view and then back to icon view to get the white background again, the same thing occurs when using the nemo file browser..

I haven't been lucky on my search for a solution, I only found someone who has posted the same problem without receiving any answers: http://askubuntu.com/questions/552075/background-of-nautilus-go-black

Please advice on the source of this problem, and on how to solve it..

Thanks in advance :)

Screenshot: http://i58.tinypic.com/35n1quw.png

Frogs Hair
November 24th, 2014, 10:02 PM
I can't duplicate the problem and I see there are 3 themes included for different desktops . If you are using Unity make sure you are using the designated theme and also make sure you have a 14.04 compatible version of the theme.

yousufinternet
November 25th, 2014, 09:49 AM
Unfortunately every thing is as it should be and the problem still exists, and not only with this theme but with every theme except the default themes (Radiance and Ambiance).. :(

Frogs Hair
November 25th, 2014, 02:38 PM
How and where were the themes installed ? Was it via PPA or manually in .themes or usr/shsre/themes ?

yousufinternet
November 25th, 2014, 02:44 PM
How and where were the themes installed ? Was it via PPA or manually in .themes or usr/shsre/themes ?

Thanks for caring to help, they were installed via PPA, I didn't try to install them manually..

Frogs Hair
November 25th, 2014, 05:08 PM
You could try installing the synaptic package manager removing and reinstalling the themes . I have a few NoobsLab themes from PPA and they work as expected. In synaptic you can right click to remove or reinstall.

yousufinternet
November 26th, 2014, 01:23 PM
Tried that also and it didn't help..

fortunately, I have found this temporary workaround to solve the problem:
https://github.com/shimmerproject/Numix/issues/121

the workaround is to disable the overly scrollbars when using custom themes, this can be done with the following command:


gsettings set com.canonical.desktop.interface scrollbar-mode normal