View Full Version : [SOLVED] Still Can't Install 14.04 on UEFI Laptop

October 8th, 2014, 12:30 PM

So, this has been something going on-and-off for the past year now with my UEFI laptop. Over the past few days, I've finally decided to sit down and actually get Ubuntu 14.04 installed on my laptop properly. Last time, I somehow installed it (13.10 probably) and had it appear on the OS selection on the Windows boot loader (not GRUB). However, when clicking it, it leads to nowhere and says that nothing is found.

Now, I've been reading a bunch of tutorials and I've turned off Secure Boot (it was off already, probably from the previous time I gave it a go) and rearranged the boot load sequence on UEFI. However, I still can't seem to boot from my CD. I'm not sure how I got it to boot from a CD before, though it was probably when I switched it to BIOS, but I can't seem to do it now. It won't boot from CD through the Windows menu on the OS selection via the Windows Boot Loader, nor when I click F12 or when I have the order made so it boots from the CD first.

Any ideas on what's going on?

October 8th, 2014, 12:48 PM
I Have no Ideas off the top of my head, but it may be useful to post some details about your laptop. brand, model , ram graphic card, ETC.
That way someone who has successfully installed on your type of machine may come to your aid.
By the way welcome to the Ubuntu Forums.

October 8th, 2014, 01:00 PM
Thanks for the welcome! I was on this forum multiple years ago, but life got in the way and I'm on a new account. Quite different now from back then, so it's really like it's all new!

Here's some information regarding my laptop:

Acer Aspire V5
Intel i7
64 Bit
8 GB of RAM
Current System: Windows 8.1 Pro (Upgraded from 8)

October 8th, 2014, 04:13 PM
Best to review these first, even more links to additional info in link in my signature:
Shows install with screen shots for both BIOS(purple) & UEFI(grub menu), so you know which you are using.
Also shows Windows 8 screens

Others with Acer, may be similar issues and how they resolved them. Most find 14.04 works better or has fewer issues than the older verions.

acer aspire s7 Dual SSD RAID - [SOLVED] Installed Ubuntu on Pre- UEFI Win
How to install Ubuntu for dual-boot with Windows 8 on Acer Aspire V5-551G. Post #3
Acer Aspire S7 can't install ubuntu - UltraBook erased RAID meta-data
Added new msata drive post #3
Acer V5-571P-6815 secure boot off worked Shows Diskpart
Acer UEFI dual boot trouble: Win7x64 - Ubuntu 12.04 LTS amd64 June 2012
Aspire E1-522 InsydeH20 Bios unlock - 7 min video

October 19th, 2014, 04:15 PM
Thanks for your help oldfred! I looked into them and did what I found appropriate for my situation and it still didn't work. Lo and behold, the ISO didn't download properly and thus the CD was a few hundred MB short of what it should have been. I'm now happily back on Ubuntu!