View Full Version : [SOLVED] 14.04 Menu bar not showing any menus

September 24th, 2014, 07:35 PM
Global menubar is not showing any menus, even though it's set to do so under Appearence > Behavior.

Mouse pointer over window:

Mouse pointer over Menu bar:

The menus don't show in windowed mode either:

Frogs Hair
September 24th, 2014, 09:29 PM
The menus appear during cursor hover on the top panel , otherwise they aren't visible.

September 24th, 2014, 10:46 PM
In the second screenshot I'm hovering the pointer over the top panel, but only the close, resize and minimize buttons show up when I do that.

Here particularily, the problem was with Firefox, because the menu bar wasn't enabled under the Customize options in Firefox. But I fixed that, and the menu bar is showing, but only within Firefox window.

This goes for all the other programs. Even though I set menus to show in the Menu bar and not in program windows, under Appearance > Behavior.


How can I get the menus to show in the global menu bar?

Frogs Hair
September 25th, 2014, 12:10 AM
Are you wanting the application menu in both the application and global menu ? If so I don't think it is possible. I also don't know if VLC has unity support because I don't use it and can't test it.

Edit: This could be a problem with indicator-appmenu , I know if the package is removed it disables the global menu integration for all applications. Try the following command and log out and back in .
sudo apt-get install --reinstall indicator-appmenu

September 25th, 2014, 10:43 AM
It seems that indicator-appmenu and its dependencies weren't installed at all. Installing them solved the problem. Thanks!