View Full Version : [ubuntu] Failed 12.10 to 14.04 upgrade data recovery help!

August 17th, 2014, 02:37 PM
Ok so tried to upgrade to 14.04 the other day and it failed . After the upgrade it hangs up in the ubuntu boot screen. So I decided to get a fresh harddrive and install 14.04 on it and I was successful.
What I can't do at this point is recover my data from the failed upgrade harddive.

I can locate my home directory but only 2 files are there.
1. Accesss to your data.desktop
2. read me.txt

I asume that this is because I incripted my home directory on the old installation.

error messages:
The Link "Access--Your-Private-Data.desktop" is broken.
This link cannot be used because its target “/usr/share/ecryptfs-utils/ecryptfs-mount-private.desktop” doesn't exist.

Is there anyway to recover my data? Please help

August 20th, 2014, 07:35 AM
I don't know your level of skill, but I suppose the first question would be have you tried or do you know how to mount the directory manually after booting from a Live CD? If I can help you figure it out, I will - but please be patient - this might be an involved process.

August 25th, 2014, 12:52 AM
Thanks T.J.

I was able to recover most of my data through an external recovery that I ran a few months ago. I guess this was good enough for me. I'm far too busy to deal with any lengthy process at the moment. I will defiantly let this be a lesson learned. Always back up your data before an upgrade!. Thank you for your response.