View Full Version : windows 8.1 Ubuntu install not detecting disk partitions

August 7th, 2014, 09:12 AM

I have a windows 8.1 laptop. I created a partition on my hard drive and burnt and Ubuntu CD (64bit) to install into the partition.

The install starts OK when booted from CD, I successfully choose a language and wireless network etc. However when it comes to the installation type to select the device for boot loader installation (where you are supposed to select the disk partition) however this table is blank. And drop down at bottom just says /dev/sda and nothing else. How do I see my hard disk??
If I click on the +- or change buttons it appears to freeze the install.

Any ideas? Slightly frustrating... I tried shrinking my main C drive an leaving the space unassigned. I then tried making it a new empty windows drive, same results. Safe and fast restart is turned off.

August 7th, 2014, 12:22 PM
/dev/sda means device scsi disk a

it might be better to boot into the Ubuntu OS first then run the boot info summary found in boot repair tool: https://help.ubuntu.com/community/Boot-Repair

you will get a link and paste that here.

why you can't see windows can be for various reasons. scritp should tell us how the disk is setup. another option is to go into windows disk manager and make a screenshot there and then post that here.

August 8th, 2014, 08:02 AM
Here is the disk partition manager in windows. The only one I have created is the unallocated space by shrinking the main C drive.

I'll try the boot info summary tonight.

EDIT: here it is http://paste.ubuntu.com/7986704/

August 8th, 2014, 09:02 AM
I had a quick look at the link and although it's new to me I spotted something about using GNU parted - so ran this which fixed the partition issues for me.

Mate thanks for the link to that boot summary. Will carry on with install and if successful will solve this up.


August 8th, 2014, 04:17 PM
You have an Ultrabook with Intel SRT for fast startup in Windows. Many have posted that with your 32GB SSd mSATA drive the SRT only uses a small part of it.
Some erase the RAID and stop using SRT and install Ubuntu / (root) into the SSD with /home on hard drive. Other only use part of it for root. And some just install / & /home to hard drive and re-enable SRT.
The Intel SRT is seen as RAID and Ubuntu used to not see the RAID at all. Now it seems to see it, but grub2 from desktop installer will not install to RAID correctly. And with SRT you do not want grub installed into the RAID, but just into the efi partition.

Some are older installs & 14.04 does work better now. And Intel SRT is essential the same from all vendors.
Intel Smart Response Technology
Some general info in post #3
Install 13.10 - just change UEFI to AHCI mode

Dell 14z & 17r with Intel SRT