View Full Version : [SOLVED] Installer crashing: E: Malformed line 2 in source list

July 23rd, 2014, 07:12 PM
Hello all,

I'm trying to fresh install 14.04 on top of 12.04, on a 64bit system where Windows 7 is already installed - to create a dual boot, but the installer is crashing.

E: Malformed line 2 in source list /etc/apt/sources.list (absolute distance)

The file in question is, in full:

deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Release amd64 (20140417)]/ trusty main restricted
deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Release amd64 (20140417)]/Ubuntu 12.04/ precise main precise restricted
deb http://archive.ubuntu.com/ubuntu/ trusty main restricted
deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted
deb http://archive.ubuntu.com/ubuntu/ trusty-updates main restricted

As this is a fresh install, I presume that the file is created by the installer. I'm booted to and installing from, a live usb (which for some reason is labelled as cdrom!)

The ubuntu partition has been formatted several times, and I've not yet got to specify my old external home drive (which I'm bringing parts of forward), so I don't know where it's picking up 12.04 from, in line 2.

Any idea what's going on?

PS I don't know if it's relevant, but I can't see the USB stick on the system, for some reason.
PPS Oddly the USB stick doesn't seem to be mounted through "media", just having mount point /cdrom

July 23rd, 2014, 09:13 PM
The line
deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Release amd64 (20140417)]/Ubuntu 12.04/ precise main precise restricted
is your problem as you thought.

What exactly do you mean by "trying to fresh install 14.04 on top of 12.04"?

Is this a clean install using the Something Else option so you can use the same partitions and format the root partition, or are you trying the "dirty" update, ie without formatting?

July 23rd, 2014, 09:48 PM
Hi ajgreeny. Thanks for your interest.

I'm trying to install 14.04 on the same partition that 12.04 was, but when I do, I use "Something Else", and reformat. My home folder is on a separate partition, but I haven't told it where I want the home folder yet, so I presume that is not involved here.

Following my first post, I created a fresh live USB, using a different stick, and tried installing with that. This time it went past the point where it crashed last time, and I thought I was home free, but it crashed again but further on. This time there was no error message, but it did get me to report a ubiquity bug (#1347900), I wasn't able to add any logs because the session didn't boot, though the automated system did attach some logs. No idea what the cause was this time.

July 24th, 2014, 05:28 PM
So the response to the bug report was that my live USB was corrupt, so I did a 3rd USB, and that, at least, went through.

My issue now is that when it finished installing, it said it needed to reboot to complete, and I clicked yes before asking my self was it expecting to reboot from the live cd or not. I decided not, and pulled the usb out. But then the system rebooted to Windows instead of giving me the option of which system to boot to, and I can't find a way to boot to Ubuntu. If I go to the boot order on the BIOS, then it just gives me the option of CD, USB, or disk, and disk boots Windows. I'm wondering if I can get to boot to ubuntu, somehow it might set up the dual boot when it finishes the installation configuration. Or am I being naive?

Oh, and it appears to have ignored the /home partition I wanted to use, and set up a new one. I had been expecting the installation process to ask me where I wanted /home, but it never did. Am I missing something? I had the partition with my data labelled as "home". Shouldn't that cause it to mount as /home? I couldn't figure a way to add the mount point during istallation without reformatting, which of course I didn't want to do as I would lose my data.

I'm still thinking I'm probably not got permissions right. The owner of the home partition I want to use is user #1000. Where did that come from? I never changed it from "jf" the original owner.

I hope someone can make some sense of this!

July 24th, 2014, 09:53 PM
Here is a link generated by Boot-Repair. Am concerned that if I use Boot Repair, it might lose the ubuntu boot instructions needed to complete the installation.


Thanks for reading.

July 24th, 2014, 11:13 PM
It looks as if when using the Something Else option you must have chosen to put the bootloader files in the ubuntu partition /dev/sda5. This was not correct and grub (the bootloader files you put on /dev/sda5) should have gone on the MBR of the disk, ie, /dev/sda, note there is no number at the end. I think, therefore that the boot-repair will sort out that problem for you, and should give you a grub menu at your next boot where you can choose Windows or Ubuntu.

With regards to the /home partition which you did not allocate as /home at the installation, that can be righted after installation if you wish to, but as a relatively inexperienced user/installer it may be quicker and simpler to start again from scratch, this time making sure you put grub on /dev/sda, not sda5, and select your /home partition in the list, choose to use it as an ext4 partition with mountpoint /home, but DESELECT THE FORMAT TICK-BOX.
I have no idea which is your old /home partition but you have sda3 and sda6 both of which could be; do you have a separate /data partition as well as /home?

One caveat: make sure you have all your personal files backed up; nothing should go wrong, but Murphy's law suggests that the one time you haven't backed up is the time that it happens, and you could lose everything.

August 6th, 2014, 06:07 PM
Thanks ajgreeny. I now have a stable dual-boot system, but not without several more dramas.

I had put the bootloader on sda5 because I'd read an article that recommended this, though I can't find it now. It is now, as you suggested, on sda.

I ended up doing a complete reinstall, as you suggested, but thought I'd be clever and chose the dual boot installation option, thinking I'd get a chance to abort when it asked me where to install ubuntu. WRONG! It just goes ahead and puts it where it thinks you want it! I happened to have a spare 8gb partition, so that's where it decided to go!

This was my third major upgrade (10.04,12.04, 14.04) and each time has been problematic, to put it mildly. I enjoy Ubuntu so much between upgrades, but I am reluctant to recommend Ubuntu to non-techies because of my experiences with upgrades. I think it's amazing that so much has been achieved by an open-source project and communities like this, so please don't think I'm complaining. I'm now very happy now with my computer running Ubuntu again!