View Full Version : [ubuntu] 14.04 LTS DVD just keeps rebooting to Grub, never installs

July 23rd, 2014, 12:57 AM
My 14.04 desktop 64 bit DVD (burned with the ISO image) checks error-free. When I try to start a dual-boot install from Grub by selecting to install Ubuntu, I get the opening Ubuntu screen with the progress dots, then my screen goes blank and returns a couple of times, then after a minute or two the PC reboots and I am back at the Grub screen. This is a new MSI AMD Mobo with Win7 Pro64 already installed and a 20 GB SSD unused space set aside for Ubuntu to be dual-boot. The system also has a 1 TB HDD. I tried several times to get this install to work and searched here in the forums. The mobo is an MSI A78M-E35 with an A8-5600K quad-core CPU. SSD is a Patriot Pyro 120 GB.
Mobo: http://us.msi.com/product/mb/A78ME35.html#hero-overview

MSI says the mobo supports "...Winki 3 is a free Linux-based O/S"... so I would not expect to have problems with drivers. But how to get the 14.04 installer to actually try?

From the DVD I also tried the "test drive" without installing. It fails the same way - not surprising I guess.

I tried a new search on "MSI A78M-E35 ubuntu" and found this is a known issue: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1312593 with a "workaround": WORKAROUND: Add radeon.dpm=0 to /etc/default/grub:GRUB_CMDLINE_LINUX_DEFAULT
but how can I do this when all I have is an ISO image?

Any help appreciated!

In the meantime I have discovered that 13.10 desktop will install and then I can upgrade. But I have another, clean, ubuntu-only install on a similar motherboard to do in near future so the same issue may arise again.

July 23rd, 2014, 03:14 AM
Your post indicates your only operating system on the computer is windows 7 and that you are trying to install Ubuntu. Where does Grub come in? The Ubuntu DVD uses isolinux/syslinux to boot. Are you assuming this is Grub or is there something else on this computer? You should have at least two options on boot from the DVD, try selecting the second option. You could also try editing the kernel line and adding nomodeset to the end of that line on boot. Hit the e key on the keyboard when you see the boot options to edit.

July 23rd, 2014, 05:51 AM
I'm having almost exactly the same problem. This is my first pc build, so apologies if I don't know what I'm doing.

Ubuntu loads from the live usb then keeps rebooting. I've also had the same problem with linux mint.

If anyone could advise on how to add radeon.dpm=0 to grub, when using a live usb, I'd really appreciate it.


July 23rd, 2014, 05:12 PM
You get grub if booting in UEFI mode on new systems.
But how is Windows installed BIOS or UEFI. You want Ubuntu to be in same boot mode.
And how you boot install media is how it installs.

If booting in BIOS mode, hit any key and f6 for nomodeset or other boot parameters.
How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
Possible boot options suggested by ubfan1
Installer BIOS screens shown

If booting with UEFI or first boot after install at grub menu, to add boot parameters.

At grub menu you can use e for edit, scroll to linux line and replace quiet splash with nomodeset.

July 24th, 2014, 03:35 AM
Yancek: When I load the 13.10 DVD it goes to a black and white screen which at the top reads Grub XX (I don't remember the version, 2.02 maybe) and has the options to try Ubuntu without installing, or install it. That's where it comes in. I did hit the e key but then I was a bit at a loss what exactly to edit since there seemed to be no folder /etc/default/ anywhere I could see on the DVD, and it's not editable anyway. I must be missing something here.

oldfred: OK I will follow those links and see if I can figure this out. I have a Lenovo x131e with Intel i3-3227U and installed 13.1 64-bit a while ago in dual boot mode (Win7 64) and it went painlessly as expected. This new install is giving me the headaches.

July 24th, 2014, 04:37 AM
This was posted a few days ago. Support for 13.10 has ended recently.

Most Windows 7 installs are in BIOS mode, so you may want to install Ubuntu in BIOS mode also. Just because system boots in UEFI mode does not mean you have to use it.
Much better to have both systems in same boot mode.

UEFI/BIOS should show two options to boot flash drive. One clears says UEFI and the other does not, often just name/label of flash drive and that is BIOS boot.

Post this from Live mode terminal.
sudo parted -l

If Windows has 100MB boot and main install and it says msdos partition then you must be in BIOS mode.
If it says gpt partitioning and you have an efi partition you must be in UEFI mode.
Windows only boots in BIOS from MBR and only in UEFI from gpt.
Ubuntu only boots in BIOS from MBR, but can use BIOS mode or UEFI boot mode with gpt partitioning.

August 7th, 2014, 11:57 PM
nomodeset seemed to be the issue. I was finally able to install 14.04 and Grub and can now dual boot Win7.64 or Ubuntu 64. Thanks!