PDA

View Full Version : [SOLVED] 14.04 no longer boots after software update



a-you
July 18th, 2014, 02:24 PM
Hi all,

I recently installed ubuntu studio 14.4/trusty 64 bit from scratch and though there were cosmetic issues of various kinds that took more than a week to deal with, the system itself was basically running fine. I mention that because indeed I had at least a week to use it and it always booted without any problems whatsoever, and ran without any apparent problems. When I did the install the installer had internet access so presumably it was downloading packages while installing. I also ran "Software Updater" at least one time shortly after doing the install from the live DVD.

Just now I ran "Software Updater" after using the system for maybe a week or more since that last update. It listed quite a lot of updates (I think it was about 135 MB to download); I happen to recall that there appeared to be 2 new kernels in that list in fact, one of which specifically said "low latency". The update seemed to go well, though the internet connection was quite flaky and several times it slowed to a crawl, but the installer went through the whole process.

At the end it said to restart, which I did. The computer booted up to where I could enter my password then it seemed to get stuck.

I'm quite sure that that first time it went so far as to get to the desktop picture, but no icons ever appeared, nor (I *think*) was any panel or any other GUI element on the desktop, just the blank desktop. After quite some time I decided to shut down the computer by holding the power button for some 10 seconds.

Then I tried restarting. This time it got through the login again (I entered my password) and went to a blank white screen and stayed like that. I tried shutting down again with the power button and restarting into recovery mode where I selected "fix broken packages" but siince I was not connected to the internet it seemed unable to do anything. Anotehr time I restarted and selected fsck which ran without any errors reported.

Finally I restarted again and this time let it sit for over 45 minutes---no difference. I did note that the mouse was still working, also the screen saving had even kicked in---not a screen saver display, just that the screen had gone black and when I moved the mouse it went back to the pure white screen.

I should add that each time I restarted by holding the power switch it was quite some time *after* there were according to the LED no disk accesses happening at all. It really did seem to be just hung. I have on rare occasions had to restart with the power switch and there were never any problems.

If it's relevant I don't know, but since installing trusty the boot sequence has been that after the grub menu and a screen tha says "Ubuntu Studio for creative..." there's a log in, after which I'm asked to select a session. Now it goes as far as the log in but never gets to the session dialog. Since installing trusty it did always go through a white screen (or white with zillions of little dark pixels) but from that it would go to the full desktop.

I write this from an install of 12.10/quantal, which fortunately I had installed on an external drive just in case there were any upgrade issues, so I have basic access though not a working machine exactly.

Any help would be very much appreciated!! Thank you so much!

Oh: if I must access the internet from a root console mode then please give me pointers on how to enter a password, which I'm certain the ISP is going to need.

unhappy_troll
July 18th, 2014, 02:32 PM
Welcome to the club. (http://ubuntuforums.org/showthread.php?t=2235005) looks like something broke between lightdm and xorg.

a-you
July 18th, 2014, 02:52 PM
But what to do??!

And first a basic question please if I may: how do I access the internet from a console?? I can get to the console with alt-ctl-F1. But the ISP is going to expect a password. I have no idea how to even get to where I could for example try


apt-get dist-upgrade

Thanks for any help in advance!

coffeecat
July 18th, 2014, 03:13 PM
The first thing to check if you experience problems after a kernel upgrade is whether the new kernel itself is the problem with your system, by booting into an older kernel. If you see a grub menu when you first boot up, select "Advanced options for Ubuntu". If you don't see the grub menu, press shift shortly after the BIOS splash screen shows to show the grub menu. Once you've selected advanced options, the first two entries in the sub-menu are for the newest kernel - don't use them. Select the previous kernel - not the recovery mode option. Boot up with that and see how you get on.

grahammechanical
July 18th, 2014, 03:43 PM
Ubuntu and its flavours do not connect to an ISP. The OS connects to a router which has already connected to the ISP. The password for the ISP should be in the router's software. If we are using encrypted transmissions between the router and the computer then a password is needed to connect to the router. Network Manager remembers that password if we set it to connect automatically. By the time we get to a desktop the computer should already be connected to the router. We should already have internet access through the router and through the ISP.

We open a terminal by using Ctrl+Alt+T or we go into a Linux console by using Ctrl+Alt+F2. In this case we need to log in with our user name and user password. Then we can run commands. What commands are you thinking of using?

Ubuntu Studio uses a special Linux kernel suitable for audio and video processing. It is called a low-latency kernel. Nothing untoward in that. Be careful when using "apt-get dist-upgrade." It will bring in software packages that "apt-get upgrade" is holding back. It does not necessarily fix things.

Linux is robust at surviving a hard power off but do it repeatedly and it causes difficulties with loading. Ubuntu loads quickly and cleanly when it loads from a good loading profile. Doing a hard power off will effect the loading profile. It make take a couple of normal shutdowns and restarts to get the loading process working efficiently. This is my experience.

Regards.

a-you
July 18th, 2014, 10:14 PM
Thanks for all the thoughts.

First, I had thought of the question of whether it might work to try booting to the older kernel; it didn't. I should have added that but forgot to mention it. It got stuck in the same place and in exactly the same way.

"What commands are you thinking of using?" the error message that was returned when I tried to do "fix broken packages" suggested --fix-missing for example. Yes I tried getting to the console with ctl-alt-Fn and could log in, but what I was trying to ask was how I would go about connecting to the internet, assuming I would have to, and it seems likely that I'll have to. I was thinking to do something along these lines:

apt-get install -f
apt-get update
apt-get dist-upgrade
on the idea that maybe some package broke during the installation and this would fix it. I'm naive when it comes to these low level issues though.

Yes I see your point about the router. Sorry, I spoke wrongly then (thanks for giving me a better understanding of how that works). But I'll certainly need to give a password to the router (which in this case might be a "bridge"). By that I mean the DSL stuff that the phone company/ISP provided. In other words, what I was trying to say was this: I have no idea how to get online from the root console (ctl-alt-Fn). I'm quite sure that it never got far enough into the startup routine that the network manager would have been running.

Looking at various bug reports, people mention trying to fix issues that sound similar by installing or reinstalling this or that package, but how would I go about installing something if even getting to the internet requires a password for the router/bridge/DSL box??

Also I understand that the low latency kernel is a normal thing. I realize that I didn't explain why I mentioned that part. It was because just before I ran the software updater gui I had been looking at what ubuntu studio put into some of the menus, which is to say that they put entries like "Audio Extras" (I forget the exact words) and under "Audio" one of the items listed as "extra" was a low latency kernel, and since I had not actually paid attention to whether with the fresh install of ubuntu studio trusty I was running had a low latency kernal or a regular kernal I thought I'd mention it, in case the low latency kernal was a change. That was all. Sorry I didn't make that clear, it was in the interest of brevity.

Re doing hard power off: I don't as a rule ever do that. It was the only way to shut down in this situation. I think I mentioned in my first post that on rare occasions I have had to do it, but maybe I didn't emphasize "rare" enough, because it has been hardly ever.

Also it's worth noting I think that this seems to be happening to various people who were using different versions of ubuntu; in my case ubuntu studio, others mention ubuntu wuth unity, etc. Ubuntu studio is based on xfce and lightdm but the others I don't know.


If anybody has any thoughts on what I should do next please let me know!! Thanks again!


Btw unhappy_troll did you ever get yours solved?

a-you
July 18th, 2014, 11:17 PM
So, thanks to (the wonderful) fsarchiver on the "system rescue" DVD I've restored the root partition to what it was just before trying to run the "Software Updater" GUI. I can hardly recommend fsarchiver highly enough.

*But* obviously it's still a screwed up situation: I now have a system that apparently I can never update!!! So the problem remains, other than the fact that at least I can do other work.

But what to do??!

a-you
July 19th, 2014, 10:51 AM
I'll go add my sob story to this launchpad thread (thanks to unhappy_troll): https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1283826

Because I have a backup of the root partition just before it was hosed, which is an unusual thing probably (I've certainly never before done such a full backup before trying to upgrade to a new version of ubuntu), maybe I'm in a position to help by for example running the updater again and this time actually remembering(!!) to mount that and copy the apt and dpkg logs after booting into another system? I don't know if that'd be helpful.

coffeecat
July 19th, 2014, 11:03 AM
Before you update again, why not check all your sources? Although a bad update in the official Ubuntu repositories does sometimes get out, this is unusual considering the testing that is done. More likely is a problem in a 3rd party repository. Do you need help with identifying what your non-official sources are?

a-you
July 19th, 2014, 02:49 PM
That's a good point. I know how to check that. It's interesting that you mention it too because just this AM I had the thought that one thing I did do before that last software update was to enable the "Pre-Release Updates (trusty proposed)" category.

I have a few ppas as well, but I try to keep those to a minimum: cinelerra, the ppa by webupd8 for oracle's java (1 app refuses to run with openjdk), one for the latest version of claws-mail, one for the latest version of gimp and one for the latest version of menulibre. I think these are all the "official" ppas for those apps, or I should say that I tried to check that before adding them. Also though I had installed cinelerra and the upgrades for claws-mail and gimp and had installed oracle's java all without problems. An upgrade of menulibre I also did do, I now recall. I did notice during the ill fated update that cinelerra and libs associated with that were being updated; don't know of course whether that was in any way problematic though. But your idea is a good one: to test these one at a time.

When there's time, by which I mean that I have only this one computer and need to be able to use it for work, so when I know that I can afford to have it not work for a while, I'll first disable all of the ppas and disable too the pre-release repository only because I had enabled that just prior, then do the updates again and see what happens.

coffeecat
July 19th, 2014, 02:59 PM
Proposed is more likely to break your system than some PPAs. The hint is in the name! :) Proposed should only be used if you wish to help with testing of updates before they are put into the main repository. Not everything that is tested in proposed makes it to the main repository for routine updates. Some display fairly major bugs and have to be withdrawn. I wouldn't be surprised if that has happened to you. I suggest disabling the proposed repository before you upgrade again.

a-you
July 19th, 2014, 08:10 PM
Thanks for that explanation. I had already disabled it today, but I'm glad to read your comments. I suspected that it could have been the source of the problems, but I didn't realize it was as risky as that ;-). The fact that it's got "ubuntu" in its name led me to believe that it wasn't risky ;-)

I'll probably have a chance to try the updater again maybe today or anyway in the next couple of days, doing it with the potentially problematic sources disabled first and enabling them one at a time. I'll let y'all know...


Well, why not now. Here goes...

1. I disabled all sources except "Important security updates" then ran the GUI "Software Updater" and so far so good

2. I enabled "Recommended updates" and everything seems fine; this time a restart wasn't asked for but I did it anyway just to test and so far so good

3. I just enabled "Unsupported updates" and the updater tool said there weren't any updates to install

Now I'll try adding the PPAs that I had. I guess I'll do these one at a time too just in case.

4. 1st is the claws-mail/ppa; again "The software on this computer is up to date"

5. now the otto-kesselgulasch/gimp-edge ppa; this time it did update gimp; restarted just to test that and all's well

6. next the webupd8team/java ppa; again a restart just to test and again all good

7. menulibre-dev/devel ppa "The software on this computer is up to date"

8. cinelerra-ppa/ppa; it updated cinelerra (this is the cv/community version of cinelerra btw)

then full shut down and boot from scratch and all good.

So indeed as I had suspected the following morning it looks like enabling updates form the "pre-released updates" source was a big mistake. As coffeecat kindly explained, it would seem that unless you are up for testing software enabling that source could be biting off more than you want to chew.

Thanks to everybody that offered comments, especially to coffeecat for following the thread over a couple of days even. Very much appreciated.