View Full Version : [SOLVED] "Unable to satisfy all constraints on the partition" error during installation

July 7th, 2014, 02:27 PM

I have a Gigabyte H61m-s2p motherboard which has UEFI

I have formated my hard drive like the following using Gparted

- I chose the GPT partition table
- 250 MB - FAT 32
- 30 GB - ETX4 for root
- 4 GB - Swap
- The rest for Home


After pressing install now I get the following


So I clicked on "Free space" as the previous pic shows then "+" and chose "Reserved Bios Boot Area"

a message appeared saying


Could you explain simply what else should I do ?

Bucky Ball
July 7th, 2014, 02:52 PM
You should be clicking on /dev/sda1 and assigning that as the 'Reserved BIOS boot area'. At the moment, it's just a small FAT32 partition. That is your UEFI partition and that is what it is banging on about.

Just for future reference, please attach images with Go Advanced or Adv Reply and use the paperclip icon. Thanks. ;)

July 7th, 2014, 07:43 PM
Thank you very much indeed, It worked like a charm.Thanks for the tip.

Bucky Ball
July 8th, 2014, 02:28 AM
Great! Glad it all worked out. Enjoy and good luck. ;)