View Full Version : 14.04: Kernel Panic and freeze

July 5th, 2014, 10:47 PM

I have been using Ubuntu to work every day for a while now, and converting a few people long the way as well.
I have installed Lubuntu 14.04 on my father in law computer to replace Windows XP.
The PC : double Pentium 4 3.40GHz, 1 Gb RAM, Graphic card: NVidia GeForce PCX 5300, HD 150 Gb.

The live CD and the install went fine, and the computer seemed OK.

However, every now and the, when starting the computer does not boot up completely and there's a kernel panic message.
Just rebooting will make it work (sometimes it takes several reboot).

However, when working with it, most of the time after a while, the computer freezes: it is not possible to interact with the computer (mouse, keyboard ...). It has to be shut off (and restarted).

I don't know what to do and where to look at: I had a look at the system messages, but I could not see anything suspect ... still I am no expert.
I have two other computers running Lubuntu 14.04 without any trouble.

If anyone could give me a hand to resolve this, it will be greatly appreciated.

Thanks in advance,

July 5th, 2014, 11:39 PM
It could be hardware related. Make sure the RAM modules are tightly in place. Run memory check from the Grub menu. Just guessing. A lot depends on what esle Linux said apart from kernel panic. Was there more to the message?


July 6th, 2014, 11:12 AM
Well, I did not see anything interesting in the kernel panic message, however it is not that easy to read.

Considering the hardware consideration, I thought so too. I checked the memory: everything was OK. So I started the computer with Windows XP, and left it there for a few hours: no freeze happened.
If I do the same thing with Lubuntu, after a while the machine will freeze.

One thing, I forgot to mention is that the freeze are totally random: some times they happen just after a few minutes of booting sometimes after 30min, sometimes it is possible to get the work done without any freeze. It freezes when you are doing something with the computer or not (e.g. while reading an article).

Any ideas, anyone ?

July 6th, 2014, 11:31 AM
Well, well, well !

It seems it is indeed, a hardware problem. I launch Windows XP again (just to confirm), and the computer froze.

So, it is not Ubuntu related. I am running Memtest (again), and if no failure are pointed out, I will open the beast and check out the connections.

Thanks for your time and sorry for the inconvenience.


July 9th, 2014, 10:20 AM
Eventually, it does not seem hardware related. The freeze with Windows XP was due to the Windows task manager when lauch in specific conditions. I ran the machine for half a day without any trouble on Windows XP.

I, then, realised there was an error message about the sis630 module:
"sis630_smbus 0000:00:02.0: SIS630 compatible bus not detected, module not inserted."

I blacklisted the module and I managed to run on Lubuntu, all the afternoon yesterday. It seems that did the trick. I mark the thread solved.

Operations to perform to blacklist the module:
- lauch his favorite text editor (in sudo mode) for the file /etc/modprobe.d/blacklist.conf
- add the following lines at the end of the file (comment is optional):
# suppression du message d'erreur sis630_smbus
blacklist i2c_sis630

- run the following command:
sudo update-initramfs -u

That's it ! Restart, to take the changes in consideration.

July 10th, 2014, 11:18 AM
It ain't over ! ! :(

Yesterday, the computer ran fine and this morning when I boot up, I got an error message and it froze there.
I rebooted and I got a kernel panic error message.

I saw a message complaining about the ieee80211 module as it's for the wifi card that is not used (the pc is connected to the net with a cable), I remove the card.

I've rebooted and it seems to work but I am not sure whether this PC is OK.

I have 2 messages about confict in dmesg, and I dont know what to do about them ? ! ?

[ 13.029308] ACPI Warning: 0x00000295-0x00000296 SystemIO conflicts with Region \IP__ 1 (20131115/utaddress-251)
[ 13.356094] fb: conflicting fb hw usage nouveaufb vs VESA VGA - removing generic driver

Any ideas ?

For the courageous minds, I have pasted the entire dmesg in pastebin (http://pastebin.com/vamEj0J7).

July 12th, 2014, 07:01 PM
I'm curious as to how old the machine is. Usually, when machines hit the 5 year age, you have to consider several things that you might not have the instinct to look at otherwise. If a cold boot usually results in a fairly stable system whereas a restart causes a freeze, I would suggest that the CPU is overheating. It could be a fault with the CPU itself whereas it could also be a fan which is either not spinning anymore or spins poorly as a result of an obstruction or dirt. The other possibility, for me anyway, is a faulty power supply. If the power supply is providing enough power for all of the components, you will be enjoying a fairly stable system. If, however, a system requires 350W and you're suddenly getting say 300W, you're opening yourself up for the possibility that a freeze will occur.

The power supply is usually the last place people look but the culprit in many strange problems. If it's not a brand name power supply, I would change that first. However, I gather that the system is fairly old and that a new power supply would cost more than the system is worth.

July 12th, 2014, 07:02 PM
I had a similar problem with a machine many years ago. I upgraded the BIOS to the latest version and that fixed the issue. Just a thought.

July 13th, 2014, 01:44 PM
I would guess the machine is about 6 to 8 years old.

Anyway, despite the error messages mentioned previously, it seems to work ok. It's been started each time so far and no more freeze: the latest operations seems to have cured the patient ! ;)

Thanks for your time and your messages.
I will wait for a week till I mark that message solved, this time ! :P