View Full Version : Ubuntu 12.04.3 LTS "Mount of filesystem failed"

July 1st, 2014, 02:45 PM
Since I had some HDD problems, I decided to install ubuntu 12.04.3 LTS instead of W7 because W7 started failing and bricked my laptop. So I used a USB to boot, connected to the internet and chose to install Ubuntu. I checked the "Download updates while installing" and "Download 3rd party software" boxes and proceeded with the installation. When the installation was complete it said "Download finished reboot computer" or something along those lines and I pressed OK. Then I got to this black screen with some lines and the last word was [OK], I waited and nothing happened so I pressed enter and it started a /killall command and shut down then I was left hanging at a purple screen so I lost my patience and powered the laptop off with the power key and started it again to be welcomed by a selection of linux versions and 2 memtests (I think this is called Grub :P) so I chose the first "Ubuntu with Linux 3.8 something something something" and I got an error saying

Mount of filesystem failed
A maintenence shell will now be started
CONTROL-D will terminate this shell and retry

I was quite dissapointed as the "Try Ubuntu" function worked perfectly but I couldn't keep all the stuff I install as I want to shut down the laptop from time to time so I reinstalled without selecting updates or third party software and the installer crashed, when I tried to send a report, the installer said that there is something wrong with the HDD and so I should check it. Is there anything I can do to use Ubuntu on this pc with a failing HDD?

July 1st, 2014, 04:09 PM
Hello, thegoldenkingclan.

Is there anything I can do to use Ubuntu on this pc with a failing HDD?Definitely so: replace the ailing harddisk with a new one. Ubuntu is not going to work on a defective harddisk any better than Windows will.

Kind regards,