View Full Version : [ubuntu] Can't boot from ubunu live cd with UEFI enabled

June 28th, 2014, 08:26 PM
Hi all,

My laptop is Dell inspiron 14z 5423.
I disabled secure boot and integrated NIC, but still can't boot in to Ubuntu with UEFI enabled. So with desperate need I enabled legacy mode and installed Ubuntu. Succeeded in installing but can't boot to the installed Ubuntu version.
I tried to this in 2013 and gave up. But now I want to install Ubuntu so badly.

P.S. I tried this with both 13.04 and 14.04.

Any help is appreciated greatly...!

June 28th, 2014, 08:39 PM
Hi Naya,

Have you tried booting into the LiveCD and using Boot Repair to set up UEFI booting? Do you have a /boot/efi partition?

June 28th, 2014, 10:47 PM
I just tried Boot repair.
Still its same. I don't have a separate boot partition so I don't think I have /boot/efi partition.

June 28th, 2014, 11:17 PM
Is the EFI partition (small 300M FAT bootable) mounted in /boot/efi? You may check with the df command in a terminal to see what's mounted where. The contents of /boot/efi should be the EFI directory containing directories Boot, Microsoft, ..., and ubuntu. The /boot/efi/EFI/ubuntu directory should contain the grub.cfg file (just a 3 line stub to pull in the maintained copy from /boot/grub) and the bootloader(s) grubx64.efi and maybe shimx64.efi for secure boot. boot-repair might have set this up, but you should have run it back in UEFI mode.

June 29th, 2014, 12:30 AM
First, for other readers, some context: Naya messaged me because I have the exact same computer model, and after a little back and forth, I suggested Naya post here.

I was able to successfully boot from my old LiveCD with the following settings (I didn't try all permutations, so less than this may be necessary):
- Turn off Intel Rapid Start
- Turn off Integrated NIC
- Switch SATA from Intel Rapid Start to ATA (maybe AHCI would be a better first try?)

If you're willing to install all of Ubuntu again, you may then be able to turn Smart Response back on. If doing so breaks Grub, hopefully you can fix it with boot-repair.

June 29th, 2014, 12:47 AM
Furthermore, I was able to boot fine when I set SATA Operation to AHCI and ATA, so I don't think you'll have trouble booting up if you install with the ATA set.

July 1st, 2014, 04:54 PM
Some additional threads

Dell 14z & 17r with Intel SRT

Not just precision models, but some issues also all Intel chips:

Ubuntu on the Precision M3800 or XPS15 Nov 2013

Dell XPS 8700 with Intel SRT - Install 13.10 - just change UEFI to AHCI mode
Dell Inspiron 3521