View Full Version : [SOLVED] How to re-size partition at Gparted?

Ursus Maritimus
June 22nd, 2014, 02:30 PM

Managed to shrink /dev/sda1 for 75g with GParted and it went fine. But it ended up unallocated, not as I tried to get it in /dev/sda6. Now, I can't unmount /dev/sda6. It will say:

The partition could not be unmounted from the following mount points:
Most likely other partitions are also mounted on these mount points. You are advised to unmount them manually..

So what should I do? How can I do it manually, tried without luck..


Thanks, J

June 22nd, 2014, 03:06 PM
You now need to expand sda2 to take up that unallocated space. That will create unallocated space inside sda2. Then you can expand sd6 to take up the unallocated space. sda2 is an Extended partition and sda6 is inside sda2 and also sd5 is inside sda2. They are called Logical partitions.

Are you running Gparted from Ubuntu installed in sda6? If so, that is why you cannot unmount sd6 and we need to unmount a partition before we can move or resize it. Run Gparted from a Ubuntu Live session.


Ursus Maritimus
June 22nd, 2014, 08:56 PM
Yes, I'm using GParted, which I downloaded and installed to sort out this problem. Did notice, that Ubuntu live session was mentioned at other topics, but thought I could do the same with GParted, which was installed to Ubuntu. But, now I do realize that it ain't the right way to do. I will try to read the live instructions again and try to use it, so it can be solved. Was hoping, that there would have been just something, which I had missed, but I guess not. Thanks, anyhow.

June 22nd, 2014, 10:54 PM
Yes, you'll have to use gparted from a live session.

There are a couple of other things to consider when you do. When you boot up the live session it will automatically mount your swap partition, sda5, which will prevent gparted from resizing the sda2 extended partition, at least until you "swapoff". You'll see the key icon by sda5 and sda2. Right click on the swap partition and choose swapoff. That will enable you to resize sda2.

The other thing to remember is that resizing sda2 will be quite quick, but enlarging sda6 by about 75 GiB will likely take several hours. Backup any important data before you start. Resizing partitions always carries the small risk of something going wrong with the loss of partitions and data. A power out, for example, during partition resizing would almost certainly lead to irrecoverable damage.

Ursus Maritimus
June 23rd, 2014, 05:26 PM
Tried with live session using instructions which I got from here: http://gparted.org/liveusb.php#linux-setup

Tried to set up USB properly, it was formatted and set up for FAT32. Then used Tuxboot, which got me using Clonezilla live. Didn't work. Then tried to use Unetbooting, which took forever to download and didn't help me any further..
Any ideas, where could I find decent instructions, so I would be able to resize the partition. Biggest amount of memory is backup from older version, because I had big problems to update. Power run out and was stuck with two systems, which wasn't really working or any idea anyway (12.04 - 12.10). Now I'm just trying to transfer the older things to newer version (14.04), but space is really limited at the moment..


June 23rd, 2014, 05:59 PM
I don't follow what you are trying to do. Do you still have the Ubuntu live CD/DVD or USB you installed Ubuntu with? If so, simply boot up into the live Ubuntu session and run gparted from there. Gparted is already installed in the Ubuntu live session.

Ursus Maritimus
June 23rd, 2014, 06:09 PM
OK. I will try that way as well. I don't know, what I'm exactly doing wrong, but I just can't get anywhere. As I said, only reason I'm doing this, is to fit the partitions on their use better. I've got a lot of pics, music, movies and documents on the old side. Yes, I can get them from there, but need to do a lot of extra work and can't move them, because lack of space.

Ursus Maritimus
June 23rd, 2014, 07:36 PM
Did try with live, no luck. I restarted the com from usb stick, Went through the boot and tried to use gpartd partition editor, but no result..

June 23rd, 2014, 09:06 PM
Did you see the little keys?
As in Post #4:
If so then still mounted and you have to click on swap and right click swap off. Swap is usually automatically mounted with live installer.

Ursus Maritimus
June 26th, 2014, 11:14 PM
Yes, I did notice them as it was said at #4 post. But for some reason, I'm not even able to boot the system. I've tried with gparted live, unetbootin, tuxboot and startup disk cretor, but every single time it has failed, for different reasons. I've understood that partition has to be mounted or swapoff. So I would be able to resize it. But I haven't been able to boot the computer and haven't been able to get that far, that I would be able to do anything for partition.
I don't know what I'm doing wrong. I've tried to read instructions and act exactly as it has been told, but not getting anywhere. What should I do?

June 27th, 2014, 12:29 AM
Some flash drives stop working, some creation tools seem to work better with some systems than others.

Did you verify that ISO was correct with md5Sum?

Also instructions for DVD or USB flash drive

How to create a bootable Ubuntu USB Flash Drive - unetbootin

Usb installer from Windows
SOLVED!!! Used rufus to create bootable USB and it worked! I've tried UUI and unetbootin before.

Most find this works best
If that does not work
Pendrive also has page on booting ISOs
Common USB BIOS boot options

Flash drive to boot in UEFI or BIOS - sudodus

Howto make USB boot drives
pendrive speed tests USB2 & USB3 various brands - user sudodus
Includes links to speed tests and lists some that do not work well.



Ursus Maritimus
June 29th, 2014, 05:10 PM
Error unmounting filesystem
Error unmounting /dev/sda6: Command-line `umount "/dev/sda6"' exited with non-zero exit status 1: umount: /: device is busy.
(In some cases useful info about processes that use
the device is found by lsof(8) or fuser(1))
(udisks-error-quark, 14)


June 29th, 2014, 06:55 PM
If that Disks screen shot from inside your Ubuntu in sda6? You cannot unmount the partition you boot from.
That is why you have to use live installer and even then usually have to also manually unmount swap.

June 29th, 2014, 07:14 PM
If you can't boot any GParted Live CD/USB or similar, have you checked your CMOS configuration?

If you can, maybe the drive you're trying to partition is physically corrupted, I don't get what you may be doing wrong.