View Full Version : [SOLVED] 12.04 Unity 2D: Want to auto-hide the launcher but this is now broken

June 21st, 2014, 04:01 AM
Somehow, my Unity desktop settings have gotten royally messed up, and I need help to restore them.

I like to auto-hide the launcher/dock (left-hand panel). This is no longer working. I have re-enabled auto-hide in System Settings > Appearance > Behavior, no luck. I used CompizSettings to re-enable the Unity plugin, no change... that thing is still sitting at the left, wasting screen real estate all the time.

I suppose I need to trash some config files. Where do they live?


June 21st, 2014, 08:30 AM
Here's a screen capture, showing the autohide option very obviously turned on, and... guess what... the launcher not auto-hidden. ](*,)

I'm fed up with it. I have work to do... I'm going back to gnome until somebody can tell me how to fix this.

June 21st, 2014, 08:50 AM
OK... a temporary workaround for me will be to use the normal "Ubuntu" (unity) session at login, rather than "Ubuntu 2D."


1. Auto-hiding the launcher used to work perfectly in Unity 2D. Now it doesn't work at all. I know that it can work, so... how to get it to work again?

2. I would really much prefer to use 2D, for two reasons. 1, one of my main uses for the machine is real-time audio, and I don't need extra CPU cycles to be taken up with composite effects in the window manager. 2, I don't like the composite effects anyway. But, to me, it's even worse to have the launcher taking up screen space all the time, so I'll do what I have to do.

A fix for 2D would be the best, though. At this point, I can think of two possible explanations: either a configuration file got messed up, and this is somehow invisible in every possible settings editor; or, one of the libraries used in Unity 2D is broken. I tried reinstalling every Unity 2D package I could find, but this didn't help.

Still hoping for an answer --

PS I hope I'm not being too crabby about this... I just really, really don't like it when something was working, then it stopped working, and there is no evident reason why, and other people's solutions that I found in Web searches also don't help. It's a quite helpless feeling... maybe that's understandable.

June 21st, 2014, 08:56 AM
If you are running unity-2d, then compiz is utterly useless.
Unity-2d uses metacity.
Did you recently get any updates, primarily for graphics drivers, maybe?
I ask, because normally when something like this happens, it is because a graphics driver glitched, or something similar.
I haven't seen any updates for unity lately ,so...

A sidenote, if you can't remember what updates have come through, look in the folder /var/log/apt. There is usually a file called history, which will have the most recent updates installed listed, per date they installed.

I don't know why System Settings >> Appearance > Behavior toggle auto-hide isn't working properly, though.

June 21st, 2014, 09:23 AM
If you are running unity-2d, then compiz is utterly useless.
Unity-2d uses metacity.
Did you recently get any updates, primarily for graphics drivers, maybe?
I ask, because normally when something like this happens, it is because a graphics driver glitched, or something similar.

No graphics driver updates.

I had just installed Qt5.0.2 from ppa:ubuntu-sdk-team/ppa. I should have mentioned it before... but, I have also "apt-get remove"d the packages and the problem persists. (At first, I was hoping it would just be a configuration problem...)

Here's the history.log entry for that[1]. I don't know the packages well enough to guess whether one of these is a system-level package that would get in the way of the window manager functioning properly.

The full sequence was:

1. Installed Qt5 from the ppa.
2. Compiled SuperCollider[2] (qt52 branch).
3. Ran the scide executable.
4. Saw some really strange desktop behavior, including the menu bar, launcher and dash disappearing completely (and not responding to hotkeys).
5. Logged out, rebooted.
6. After login, pretty much everything in Unity 2D was working, except auto hide. After multiple reboots, it still fails in 2D.
7. At some pain, recompiled SuperCollider against qt4. Now it's (finally) running again.

So it would seem that either the qt5 installation, or some faulty qt5 calls in one of the SuperCollider executables, corrupted something that Unity 2D depends on. If the latter... it would be quite troubling indeed to consider that user-level code (which I know does not touch system-level configuration) could break a system component, seemingly permanently. ("Permanent" in the sense that it persists after reboot.)

Anyway, I'm out of time to experiment with this today. Perhaps tomorrow I'll do a more thorough search for qt5 packages to remove, reboot, and try again.


[1] From history.log:

Start-Date: 2014-06-21 10:07:29
Commandline: apt-get install qt5-default qt5-qmake qttools5-dev qttools5-dev-tools qtdeclarative5-dev libqt5webkit5-dev
Install: qt5-qmake:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4), libqt5network5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libqt5sql5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), gir1.2-gst-plugins-base-1.0:amd64 (1.0.8-1~ubuntu12.04.1~ppa1, automatic), libgstreamer-plugins-base1.0-dev:amd64 (1.0.8-1~ubuntu12.04.1~ppa1, automatic), libqt5clucene5:amd64 (5.0.2-4ubuntu1~precise1~test2, automatic), libqt5quickparticles5:amd64 (5.0.2-2ubuntu1~precise1~test4, automatic), libunistring0:amd64 (0.9.3-5, automatic), debhelper:amd64 (9.20120115ubuntu3, automatic), libqt5test5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libqt5widgets5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libxslt1-dev:amd64 (1.1.26-8ubuntu1.3, automatic), libqt5dbus5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libqt5quick5:amd64 (5.0.2-2ubuntu1~precise1~test4, automatic), qtbase5-dev-tools:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), dh-apparmor:amd64 (2.7.102-0ubuntu3.9, automatic), libqt5sensors5:amd64 (5.0~git20130507-0ubuntu2~precise1~test1, automatic), qtsensors5-dev:amd64 (5.0~git20130507-0ubuntu2~precise1~test1, automatic), po-debconf:amd64 (1.0.16+nmu2ubuntu1, automatic), libgstreamer1.0-dev:amd64 (1.0.8-1~ubuntu12.04.1~ppa1, automatic), libqt5xml5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), qttools5-dev-tools:amd64 (5.0.2-4ubuntu1~precise1~test2), libqt5opengl5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libxcb-image0:amd64 (0.3.8-1build1, automatic), intltool-debian:amd64 (0.35.0+20060710.1, automatic), libqt5gui5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libqt5v8-5:amd64 (5.0.2-3ubuntu1~precise1~test1, automatic), libpcrecpp0:amd64 (8.12-4, automatic), libgstreamer-plugins-base1.0-0:amd64 (1.0.8-1~ubuntu12.04.1~ppa1, automatic), libqt5help5:amd64 (5.0.2-4ubuntu1~precise1~test2, automatic), libqt5location5-plugins:amd64 (5.0~git20130805-0ubuntu1~precise1~test3, automatic), gettext:amd64 (, automatic), libxcb-icccm4:amd64 (0.3.8-1build1, automatic), libqt5opengl5-dev:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libqt5webkit5:amd64 (5.1.1-1ubuntu2~precise1~test3, automatic), libqt5quicktest5:amd64 (5.0.2-2ubuntu1~precise1~test4, automatic), qtbase5-dev:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libqt5core5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libqt5webkit5-dev:amd64 (5.1.1-1ubuntu2~precise1~test3), qtchooser:amd64 (26-3ubuntu2~precise1~test2, automatic), libglib2.0-dev:amd64 (2.32.4-0ubuntu1, automatic), libqt5designercomponents5:amd64 (5.0.2-4ubuntu1~precise1~test2, automatic), zlib1g-dev:amd64 (, automatic), libxml2-dev:amd64 (2.7.8.dfsg-5.1ubuntu4.9, automatic), qtlocation5-dev:amd64 (5.0~git20130805-0ubuntu1~precise1~test3, automatic), libqt5designer5:amd64 (5.0.2-4ubuntu1~precise1~test2, automatic), libxcb-sync0:amd64 (1.8.1-1ubuntu0.2, automatic), qttools5-dev:amd64 (5.0.2-4ubuntu1~precise1~test2), libgettextpo0:amd64 (, automatic), libqt5sql5-sqlite:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), gir1.2-gstreamer-1.0:amd64 (1.0.8-1~ubuntu12.04.1~ppa1, automatic), libpcre3-dev:amd64 (8.12-4, automatic), html2text:amd64 (1.3.2a-15, automatic), libqt5location5:amd64 (5.0~git20130805-0ubuntu1~precise1~test3, automatic), libqt5concurrent5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), qtdeclarative5-dev:amd64 (5.0.2-2ubuntu1~precise1~test4), libgstreamer1.0-0:amd64 (1.0.8-1~ubuntu12.04.1~ppa1, automatic), libqt5qml5:amd64 (5.0.2-2ubuntu1~precise1~test4, automatic), libmail-sendmail-perl:amd64 (0.79.16-1, automatic), libsys-hostname-long-perl:amd64 (1.4-2, automatic), libxcb-render-util0:amd64 (0.3.8-1, automatic), qt5-default:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4), libqt5printsupport5:amd64 (5.0.2+dfsg1-7ubuntu12~precise1~test4, automatic), libqt53d5:amd64 (5.0~git20130731-0ubuntu1~precise1~test3, automatic)
Upgrade: libqt4-declarative:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-qt3support:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-opengl-dev:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), qdbus:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-test:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-script:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-designer:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-network:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-dbus:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-opengl:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-xmlpatterns:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-sql-sqlite:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-dev:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-help:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqtcore4:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), qt4-qmake:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libxml2:amd64 (2.7.8.dfsg-5.1ubuntu4.8, 2.7.8.dfsg-5.1ubuntu4.9), libqt4-sql:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-svg:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-xml:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqtgui4:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), qt4-linguist-tools:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1), libqt4-scripttools:amd64 (4.8.1-0ubuntu4.8, 4.8.1-0ubuntu5~precise1~test1)
End-Date: 2014-06-21 10:08:59

[2] https://github.com/supercollider/supercollider

June 23rd, 2014, 12:06 PM
For what it's worth... I am closing all of my questions here about Unity. SOLVED by dumping Unity.

I will try Gnome Shell for awhile.

Unity, at least in 12.04, simply has too many bugs. Just a few things that I've seen today -- only today!

- Menubar fails to update for the current application: Alt-tab to another window, and it shows the title of the previously-focused window. Huh?

- Sometimes it doesn't show the close/minimize/maximize buttons. I have to click on a menu before it will show them. Huh?

- I have auto-hide turned on for the launcher. After some period of usage, it stopped revealing the launcher when I pushed the mouse to the left side. Huh?

- At one point, Alt-F1 (to reveal the launcher) displayed the launcher underneath an application window. Huh?

It's a pity... I really did like some aspects of its design. But too many things just don't work right, or they're too easily breakable. So, enough...