View Full Version : [SOLVED] Upgrade to Lubuntu 14.04 breaks J-Pilot

Timothy Taylor
June 18th, 2014, 05:25 PM
I have upgraded to Lubuntu 14.04 and cannot get J-Pilot to sync with my PDA.

This was working fine in my previous Ubuntu 10.04 system, but it seems that I also need the pilot-link package which is missing from the software centre now???

June 18th, 2014, 07:43 PM
So ... I haven't used jpilot in ... er ... 10 yrs, but software center doesn't display all the packages available. Install synaptic and try that ... or use apt-get directly or aptitude ...

Might need to look for a PPA - I dunno.
sudo aptitude install jpilot worked here. No PPA needed.

Timothy Taylor
June 20th, 2014, 11:39 PM
Got it working.

The requirements listed on the J-Pilot website (http://www.jpilot.org/requirements.html) specify that pilot-link is installed. Unfortunately, http://www.pilot-link.org/ no longer exists. I managed to track down a copy on SourceForge (http://sourceforge.net/projects/pilot-link/).

This is a new version of J-Pilot in the 14.04 repository, which apparently requires users to be members of the dialout group.