View Full Version : [SOLVED] (12.04) Unity 2D seems to be eating alt-shift-right-arrow

June 17th, 2014, 09:46 AM
Okay... another keyboard mapping question with Unity (2D) in Ubuntu 12.04.

I use org-mode in Emacs daily. It uses Alt-Shift-LeftArrow to promote a subtree (move it one level to the left) and Alt-Shift-RightArrow to demote a subtree.

Alt-Shift-LeftArrow works perfectly.

It seems that Emacs never receives the key combination Alt-Shift-RightArrow. That is, if I ask for help on a key binding (ctrl-h k ... keys...), Alt-Shift-LeftArrow also the appropriate help page, but Alt-Shift-RightArrow does nothing at all.

I suspect this means that Unity is swallowing Alt-Shift-RightArrow and refusing to pass it along to the application that has focus. Further evidence: Using the SuperCollider programming language, I can have it print something on every keystroke received by a Qt GUI widget. If I do Alt-Shift-LeftArrow, I get three events, one for each key. If I do Alt-Shift-RightArrow, I get events for Alt and Shift, but not the arrow key. Therefore, the issue is not specific to Emacs. Something system-wide is killing this particular key combo.

I've checked the system settings Keyboard control panel, and there is no active keyboard shortcut for Alt-Shift-RightArrow. So... where do I look now? (I mean, where do I look apart from switching back to the Gnome desktop...)


June 22nd, 2014, 12:11 PM
Update -- for... complicated... reasons, I had to switch to Unity (not 2D). Now, alt-shift-right behaves as I expect, but alt-shift-up shows a zoomed out view of all the windows in the workspace.

The thing is, nothing in System settings > Keyboard > Shortcuts is bound to alt-shift-up. That means this is a hidden shortcut that you can't configure.

It's becoming moderately annoying... you know, many things in Unity are starting to win me over. But then, every so often, there's some weird thing like this where there seems to be nothing you can do about it. It doesn't appear in any configuration dialogs; nor does it appear in Ubuntu Help (making it a hidden, non-configurable, undocumented shortcut!).

Oh wait... here: http://askubuntu.com/questions/28086/what-are-unitys-keyboard-and-mouse-shortcuts

Shift-Alt-Up: Expo mode for all windows in the current workspace only.

But CCSM doesn't expose this shortcut, so I can't turn it off. And if I try to disable the entire Expo plugin: Expo is required by the plugins "Ubuntu Unity Plugin". ((hmph)). So, cheers... I'm not allowed to invoke org-shiftmetaup by keybinding in Emacs + Unity.

Anything I can do about this, except ditch Unity for a less intrusive window manager? (But there are so many other things I like in Unity...)


June 23rd, 2014, 12:06 PM
For what it's worth... I am closing all of my questions here about Unity. SOLVED by dumping Unity.

I will try Gnome Shell for awhile.

Unity, at least in 12.04, simply has too many bugs. Just a few things that I've seen today -- only today!

- Menubar fails to update for the current application: Alt-tab to another window, and it shows the title of the previously-focused window. Huh?

- Sometimes it doesn't show the close/minimize/maximize buttons. I have to click on a menu before it will show them. Huh?

- I have auto-hide turned on for the launcher. After some period of usage, it stopped revealing the launcher when I pushed the mouse to the left side. Huh?

- At one point, Alt-F1 (to reveal the launcher) displayed the launcher underneath an application window. Huh?

It's a pity... I really did like some aspects of its design. But too many things just don't work right, or they're too easily breakable. So, enough...