View Full Version : [SOLVED] 14.04 choppy, garbled, distorted sound with fresh install

June 12th, 2014, 04:15 PM
Have reinstalled 14.04 a couple of times on this Asus Z97-A with i7 4770A 3.5 GHz mpu, 16 GB, dual 120 GB Samsung SSDs on LVM over (mdraid) Raid 1 plus dual 1TB WD HDD LVM on Raid 1. /var, /home, /tmp are on the HDDs, root and /swap on the SSDs. Video is on the svga port (I should try the HDMI and its sound...) No additional pci cards installed.

The sound from the motherboard's analog jack is distorted; the system sounds crackle and then echo for 3-4 seconds. Here's the strange part: playing a YouTube video starts with distortion; moving the mouse clears it up momentarily until I stop moving the mouse. In full-screen view the distortion clears up after a second and remains OK.

The system was built from the server distribution (to easily get to the LVM on RAID setup) and then ubuntu-desktop was added. The sound problem was present immediately at first boot after installing desktop. I have added some packages since then but have not seen any change in the sound.

I think this might be a problem with the relatively new Z97 chipset. A previous 12.04 -- 13.10 system had Z77 chipset with the same LVM+Raid setup and server-based install and no sound problems. Anyone else seeing this?

I will start to troubleshoot and post what I find.

June 14th, 2014, 04:28 PM
The same here, with a fresh install of Xubuntu 14.04 this morning, on brand new hardware...
Asus Z97-K
Intel 4770
8Gb ram


June 14th, 2014, 04:36 PM
Haven't had much time to chase this down yet, maybe this weekend. I did add myself the the audio and video groups then logged back in but it made no difference.

June 27th, 2014, 05:06 AM
Sounds great through HDMI, so the problem definitely is with the analog side. Less motivated now to chase it down but will try to find some time.

Marking this one as solved.

July 17th, 2014, 07:14 AM

I just flashed to a new bios, and when I went into bios, I noticed an option I didn't see previous time (or I missed it) :
- Depop under onboard devices configuration and with the audio settings.
I unchecked it, and now the sound is fine.

Maybe you could try this simple one even if problem is solved for you, juste to check if it is the real solution?


July 17th, 2014, 04:32 PM
I had the same issue and it was related to the relatively new Z97 chipset. The issue is specified in launchpad here:


Installing the latest linux kernel (3.16) solved this issue for me. Using Ubuntu on a Z97 build also revealed other hardware compatibility issues (which is apparently common when you're a Linux user and you're on the bleeding edge of things). I documented some of these other fixes here: https://github.com/Nerdylicious/How_To_Fix_Ubuntu_Compatibility_On_Intel_Z97_Build