PDA

View Full Version : [SOLVED] Cannot boot into new install of Ubuntu 14 Server



rob67
June 11th, 2014, 11:57 PM
Seems like a fair few people have had similar problems, but I've tried all the suggestions in other threads to no avail.

I have installed Ubuntu 14.04 on a HP ProLiant ML310e Server via burning ISO of the Ubuntu Server and following the process.

I have 2 HDDs which I want to set up as RAID 1, and during the Ubunutu Server install, it gave me the option to set this up as it installed, so I did.
Install processed fine, with no reported errors.

Upon rebooting, the system does not even attempt to boot from HDD, and just from CDROM and NIC, both of which obviously fail.

I then booted into Live CD and ran Boot Repair which gave me a heap of commands to run in Terminal and eventually game me this report: http://paste.ubuntu.com/7630512/

Then in the DISK Utility it shows my two physical drives each partitioned as "master boot record" "Linux Raid auto (bootable) and Linux Raid Member (dev/sda1 and dev/sdb1)

One drive (sda) has partition 1 (main, linux raid member), plus extended partition 2, plus swap partition 5 plus free space 1.1MB

Second drive (sdb) has just partition 1 (main linux raid member) plus free space 1.1MB

Disk Utility also shows the RAID Array, /dev/md/0, contents ext4 mounted at /mnt/boot-sav/md0

Here are some screenshots:

http://i.imgur.com/UgSP6Wb.png
http://i.imgur.com/ZtmGXAP.pnghttp://i.imgur.com/uaEM3Mo.png


And still, upon restart, it just won't boot - just goes straight to CDROM and NIC.

The BIOS boot order has Hard Drive C: (See Boot Controller Order) as #1 And Boot Controller Order just has one option, which is PCI Embedeed HP Dynamic Smart Array B120i Controller.
Wonder if this is anything to do with it, as I'm not using the HP's own Raid software (tried that, also didn't work).

If I use the boot override to force it to boot from HDD, it doesn't even look like it tries and goes straight to attempting to book from CD-ROM

Any advice, most appreciated. Have been trying / reinstalling / trying for days now!

Thanks

oldfred
June 12th, 2014, 12:20 AM
Please attach screen shots not post in line. Not everyone has high speed Internet and it locks up their system.
You can easily attach with Go Advanced editor and the paperclip icon.

I do not know RAID, but normally you install grub to the root of the RAID not the normal MBR of the drive.

Boot-Repair says it did this to both sda & sdb
Reinstall the GRUB of md0 into the MBR of sda

I know with BIOS RAID, it installs this way, you mount the partition p1 and install to the root or beginning of the RAID:

sudo mount /dev/mapper/isw_cdjacjeebj_VOLUME_0p1 /mnt
sudo grub-install --root-directory=/mnt /dev/mapper/isw_cdjacjeebj_VOLUME_0

Are drives connected to the RAID controller or directly to motherboard ports?

Not sure if your hardware is part of the issue or not.

rob67
June 12th, 2014, 12:57 AM
Hi,

Thanks for the reply.

Have solved this now, after talking to HP Support.

Was actually, as you suggested, a Hardware (well BIOS) setting issue. The BIOS was set to only show the HP Smart Array Controller, so the system could not see the SATA HDDs on boot at all (I am not using the HP Smart Array Controller).

Had to switch up the SATA settings in BIOS from using Smart Array to using SATA AHCI Support.

Now it all works!

Thanks anyway