View Full Version : LiveUSB will not Boot on Lenovo v570

June 10th, 2014, 12:01 AM
I have a Lenovo v570 that I'm trying to do a clean install of trusty on and for the life of me I can't find any way to get it working. When I try to boot from the SD card it's on, it doesn't even list it in the boot menu and the SD card is the first one listed on boot order. I installed it from 'Startup Disk Creator' from another device with trusty but still no luck. I've heard that there are a lot of problems with UEFI, which I'm guessing is the issue here but when I go into the BIOS, it mentions nothing about UEFI. I've tried different USB sticks, SD cards, DVDs, and CDs but still no luck. Does anyone know how to fix this?

June 10th, 2014, 04:56 AM
Someone with Lenovo posted this a while back.

Lenovo's buggy EFI Bios is will not boot from a DVD at all unless you enable 'legacy' (which you can't do because it screws with Windows 8!)
The work around was to turn ON 'Legacy' boot mode in the BIOS and turn OFF "secure-boot" mode from locking out Ubuntu), and also make sure to turn OFF 'Legacy' SATA AHCI to ATA.
Then I installed Ubuntu from a USB stick (because these settings would only boot the Ubuntu installer from USB, but not DVD).

Another lenovo solution copy grubx64.efi to bootx64.efi & boot hard drive not anyother entry

Lenovo Community Bios Access
Lenovo Active Protection System™ – for hard drive
[SOLVED] Lenovo Y580 with working bumblebee on 12.10 - NVIDIA 660M
screen brightness was 0 during installation, use f12
Lenovo Z580 laptop

Installing GNU/Linux on a 2014 Lenovo Thinkpad X1 Carbon
Lenovo IDEAPAD Y410P - In My BIOS I set Boot Legacy Support But i set Boot UEFI First.