PDA

View Full Version : Steam stuck at "UPDATING STEAM" screen.



Refrozen
July 25th, 2006, 09:40 PM
Response on Cedega Forums is rather slow, so I figured I'd post this here to see if some of you could help.


Finally, I got Steam to install. I had to open a console and run "cedega SteamInstall.exe," rather than using the UI, but that doesn't matter: Steam installed... I think (there's no files for it yet? That I can find anyway? :( )

After the install, Steam immediately launches itself and goes to a "Updating Steam..." screen. This screen seemingly uses 100% CPU indefinitely, and nothing, not even the cancel button have any effect. The cancel button RESPONDS (i.e., gets "pressed" in looking), but never does anything. Steam seems to never pass this point.

Hmm? Any advice?

rittub
August 19th, 2006, 05:42 PM
I have the same problem :(

GameGod
October 26th, 2006, 04:25 AM
I'm having the same problem too... Steam used to work on my PC too, so it might have been a WINE update that broke it.

This person had the same problem with Cedega:
http://transgaming.org/forum/viewtopic.php?t=6506
... however, it looks like the solution is Cedega-only...

Anyone else?

T3h_Dohtem
October 26th, 2006, 02:26 PM
Im having a similar issue.
Steam runs, updates to 26%, then closes. When I try to run it again, same thing.

GameGod
October 26th, 2006, 10:02 PM
T3h_Dohtem: The 26% problem is a different issue.

However, last night I had an epiphany and I fixed my "Updating Steam..." / "0%" problem: I disabled moblock.
If you're running PeerGuardian or Moblock, they'll block Steam from connecting.

Before I run Steam, I just do a "sudo killall moblock", and it's fixed.

Hope this helps someone!
(Make sure you have your firewall turned off as well...)

soxs
October 30th, 2007, 01:37 PM
Quote from winehq.org

26% Bug Workaround

Run this from the directory you installed Steam to:


nice -n 19 wine Steam.exe

If that doesn't work try this:


wine steamTmp.exe SelfUpdate "Steam.exe" 14

If all fails try this before the previous command:


rm ClientRegistry.blob

Uchihakid23
November 20th, 2007, 10:50 AM
Sorry to seem like a newb, but how//where do I add this code?

GameGod
November 20th, 2007, 03:52 PM
Uchihakid23:

You'll want to open up a terminal, and then change directories to the directory where you installed Steam to. If you installed Steam in the default directory, you'll want to open a terminal and type the following into it:


cd ~/.wine/drive_c/Program\ Files/Steam

... then continue to run the commands in the post above.

kerryhall
January 19th, 2008, 03:26 AM
Ahhh thank you so much GameGod, I didn't realize Steam couldn't update if you are running MoBlock! :)

jre
January 21st, 2008, 07:32 PM
Before I run Steam, I just do a "sudo killall moblock", and it's fixed.
With the debian packages from moblock-deb.sf.net this will cause troubles. Better do a "moblock-control stop" instead. (Otherwise the iptables rules still exist and send traffic to moblock which is no more running. Therefore all traffic would be stuck forever).
Instead of stopping noblock you can also remove the "steam" lines from the blocklist or whitelist the blocked IPs (see what is blocked in /var/log/moblock.log). Have a look at /etc/moblock/moblock.conf.

Syo
February 11th, 2008, 12:25 AM
Just edit /etc/moblock/moblock.conf and add

IP_REMOVE="valve;limeli"


Then reload moblock.


Once its finished reloading steam should work again.

vahnx
February 24th, 2008, 04:05 AM
I tried the stop and kill moblock, and there is no /etc/moblock/moblock.conf for me. I guess I don't have this 'moblock' installed and I still can't get passed the Updating Steam... part. Please, anyone help?
EDIT: Google for steaminstall.exe and use that instead of the msi.

mikeym
September 9th, 2009, 03:23 PM
Hmmmmm..... Steam does not like MoBlok.

I've found that I needed to remove the following IPs (I did it from within settings in Mobloquer)


qwest communications corporation
limelight networks
valve corporation

Not sure if this is strictly speaking "safe". Probably best stopping MoBlock by hand when you run steam then restarting it.

jre
September 9th, 2009, 10:38 PM
By now blockcontrol (which you have installed, if you use mobloquer) supports allow lists. So you may add the contents of the steam allow list from iblocklist.com (http://list.iblocklist.com/?list=steam) to /etc/blockcontrol/allow.p2p

executorvs
September 9th, 2009, 11:35 PM
thank you for that. I know someone who will be quite happy to hear it.

Ankhwatcher
January 31st, 2011, 10:56 PM
By now blockcontrol (which you have installed, if you use mobloquer) supports allow lists. So you may add the contents of the steam allow list from iblocklist.com (http://list.iblocklist.com/?list=steam) to /etc/blockcontrol/allow.p2p

Would you mind showing an example of how that is done?
I can't figure out how to allow ranges in BlockControl.
Also do the IP Addresses just need to added for incoming, or for outgoing too?

Thanks,
ANkh

s.fox
February 1st, 2011, 12:16 AM
http://s3.postimage.org/wwatx561a/Thread_Necromancer.jpg

Thread Closed.