View Full Version : U 14.04 Desktop 64 GPT/UEFI Fail

June 6th, 2014, 07:37 PM
I am trying to set up Ubuntu 14.04 Desktop 64-bit in a secure boot configuration, on a bare motherboard and a clean 3TB RAID 1 volume, and struggling to get all the pieces to fall into place.

My setup is an Asus P9X79-E WS motherboard and two 3TB Seagate SATA Barracuda HDDs running off the on-board Intel SATA RAID controller in a RAID 1 (mirrored) configuration. No legacy Windows installation or dual boot, I'll run Windows in virtual machines later.

I got everything up but Gparted only recognized about 1TB of the array and none of the 2TB of unallocated space, indicating a BIOS/MBR installation and not a UEFI/GPT installation, so I started over. I dinked around with the BIOS/UEFI firmware boot configuration a bit and on re-boot noticed that the SATA RAID Option ROM switched itself from RSTe to IRST, and re-installation hangs.

So, several problems:
- How do I get GPT up for a RAID array so that Gparted can manipulate volumes on the array? I wonder whether this hardware is up to the task and whether I'm better off with a modern Adaptec hardware RAID card.
- How do I then configure the BIOS/firmware for secure boot, and how should I partition the array or will the installer do that for me?

June 6th, 2014, 09:02 PM
You cannot use gparted for RAID.
The desktop installer has never supported RAID.
You may be able to use the server installer and just add the desktop of your choice.

With 12.04 there was the alternative installer which was for RAID & LVM. But with 12.10 they did away with the alternative installer and said they would include those features in the desktop later. LVM is now available in Desktop but RAID is not. Not sure if you can add RAID drivers in live mode and if installer will then see them or not.

Elimination of Alternative installer for 12.10 and no RAID support directly for Desktop.

Are you using BIOS RAID or mdadm?

Do not use gparted on RAID.
Don't bother with RAID 0 unless you have a specific need for speed without data redundancy, since if one drive goes out, you lose the whole array.
parted (3.0) completely removes filesystem creation and modification support, except for filesystem probing to determine what's in a partition.

June 6th, 2014, 10:26 PM
Thanks for getting back on the storage question.

I understand how what you're saying about RAID certainly applies to "fakeraid" or software RAID, as regards both gparted and the installer. The links you provide all seem to address software RAID. What I'm currently using is the on-board Intel SATA RAID adapter, which seems to be managed by mapper, which seems akin to mdadm, and in any event seems to be fakeraid. My take-away is that using fakeraid in this fashion isn't feasible.

I also agree with you about the worthlessness of RAID 0. RAID 1 on my workstation has saved my bacon on countless occasions, though. YMMV but I highly recommend it.

The question, then, is what about hardware RAID, something like the Adaptec 7805/6805/5805, which is RAID-on-a-chip? I would think that this presents the OS, installer, and gparted with the array as a single device rather than a number of discrete devices, with the consequence that gparted and the installer would work. Any thoughts on this?

I seem to recall using gparted to manipulate partitions on a RAID 1 set on a WinXP workstation a while back, running off an Adaptec 1420SA Host Raid ["fakeraid"] card. It just worked. That card in general worked far better than the on-board Intel SATA RAID controller for which it substituted. This experience may not translate, I realize, but could be instructive.

I appreciate any thoughts and comments in advance, and thanks again.

June 6th, 2014, 10:33 PM
I also am still wondering about the correct BIOS/firmware configuration, and partition configuration, for a secure boot installation of Ubuntu 14.04 Desktop 64-bit.

**Sorry, I take that back. I'm reading your last link and will take that topic elsewhere if I have any further questions.

July 7th, 2014, 02:21 AM
Here's the solution to some of the above-mentioned problems, at least.

First, use hardware RAID, not software RAID (a/k/a fakeRAID). The former is RAID-on-a-chip, or ASIC-based. The latter is any implementation that requires a driver, whether the RAID hardware is motherboard- or adapter-based. Notwithstanding that RAID ASICs have been around for decades, my personal experience is that no motherboard manufacturers implement on-board hardware RAID. Most use some kind of Intel software RAID chipset. From my experience and all other indications, any software RAID implementation requires a time-consuming kludge either on installation or other significant administrative event such as a drive failure, array re-build or re-configuration, or partition management.

Hardware RAID, on the other hand, just works. On this occasion, the Adaptec adapter-card-based ASIC presents the RAID 1 (i.e., mirrored) array to the OS as a single GPT drive (here, 3TB), recognizing its full capacity. GParted then creates and formats all necessary partitions without a hitch. No drivers are necessary. An eight-channel Adaptec card runs $600-$650, which seems expensive at first. Still, for a high-reliability and -availability implementation it is very cheap insurance relative to the value of one's time. I recommend this approach highly. Be aware that the Adaptec HostRAID products are software RAID, albeit more functional and intuitive than other software RAID implementations I have worked with.