View Full Version : [SOLVED] Grub repair failed. Report Attached

May 28th, 2014, 09:35 PM
Hello guys,

I'm on HP 655.

I have pre-installed windows 8. I installed Ubuntu 14.04 after creating an empty partition in windows 8.

After successful installation, my grub failed to install because I couldn't see any menu while booting.

I tried ubuntu repair ISO boot disk but it failed and generated this report for me.

Can anyone please check and let me know how can I fix it?


May 28th, 2014, 10:39 PM
Were you connected to the internet when you ran boot repair? I ask because the says that it could not access certain Ubuntu archives and that could be the reason why the repair failed.


May 29th, 2014, 12:22 AM
You also have a HP which seems to have issues.

Others have posted this:

It seems hp firmware do not allow you to boot anything other than windows. Hence no ubuntu option in the UEFI. To work around it
1) press esc key while booting to access start up menu 2) press F9 for boot devices menu.
[SOLVED] Trying to install Ubuntu as dual boot on Windows 8.1 desktop HP500
HP Envy 17 zero brightness, use f3 to change
acpi=off worked for HP2000
HP Envy M6
HP Envy - Legacy boot seems to mean either UEFI or Legacy depending on which is found to boot from
Installing Ubuntu on HP Envy-6 Details of what worked post #11
HP 4545s Secure boot off, manually copy files.
HP Manually renamed files to make it work.

May 29th, 2014, 05:46 AM
Hello all,

Thanks for your help!

I have successfully managed to repair my GRUB.

The Issue:
My hard disk partition type was GPT and I was trying to repair GRUB for MBR.

The Solution:
I was selecting the legacy boot type from my SETUP (by pressing ESC key first and then F-10 key, on boot) that's why it was trying to repair for MBR type hard disk. I just turned on the secure boot option and disabled the legacy boot and booted with my GRUP Repair USB and then repaired the grub. It went smooth as silk!