View Full Version : [ubuntu] Problems with instaling GRUB2

May 24th, 2014, 07:00 PM
Hi Guys,
I am kind of a Linux newbie, and i just wanted to install Ubuntu alongside windows 8.1 on my Lenovo Ideapad y500. After burning the ISO to a stick and booting from it, I had my first Problem: after the purple Splash Screen i only saw a blinking white cursor. As it didnt go away, I tried pressing some buttons, and noticed, that if i press the left and the right Arrow Keys, my PC played a sound. After retrieing to boot from the disk over and over agaqin, I somehow pressed the Escape key on accident during the splashart and i could select my language and select, whether i want to install Ubuntu, try Ubuntu and several other things. After pressing Install Ubuntu it was the same as before: Black screen, blinking cursor and sounds when i pressed the left and the right Arrow Keys. So I tried every single Option, until i figured out i had to use nomodeset. After that worked, i could finally instal Ubuntu. The installation process was completely normal, but after a while, an errormessage popped up: >>grub install/dev/sda<< failed.This is a huge Error. (Translated from German ;)). I suspect the problem is that sda is the SSD, which Windows uses to boot faster. There is nothing i can read with Windows on that Disk and its a unknown Formatation. It gets used by Intel Rapid Technology. I think the Computers MBR is on that Drive, or at least, thats what it looks like. Can anybody help me with this Problem? I realy want to install Ubuntu, WIndows has such a high RAM usage since a couple of weeks!
In best Regards,
Nico Gründel

May 24th, 2014, 08:36 PM
Take a look at https://help.ubuntu.com/community/UEFI
The new machines with Windows 8+ preinstalled are all UEFI, and come with gpt partitioned disks, which means you can't even install grub to the MBR anymore without making another 1M partition with the grub-bios flag. Stick with the grub-efi, which works within the UEFI framework, and allows you to keep the Windows bootoaders as well. From the Windows side, turn off things which short-circuit the boot process, like the power options for fast boot. From the UEFI Settings/BIOS, give yourself a "normal" vs a "fast" boot speed (or a non zero value if possible).

May 24th, 2014, 11:17 PM
Usually you have to turn the Intel SRT off as that confused grub install. The SRT uses RAID and installer is not set to install to RAID nor should it in your case.

Lenovo Ideapad Y500 LiveUSB Problem, also brightness

Slightly different models, but may be similar issues.

lenovo u310 - install Ubuntu to part of SSD Post #19
Lenovo U410 How to
Lenovo IdeaCentre K410 Pentium 64-bit

Discovered that on my Lenovo, if I press F12 repeatedly on startup, it takes me into a Boot Order menu. If I select Windows there, it boots into Windows. I also found that to get into BIOS at startup on my Lenovo tower, you press F1 rather than the F2 I'm used to on other computers.

May 25th, 2014, 09:06 AM
Just if anybody wonders, i solved my Issue: I always starter in not EFI Mode but in Legacy Mode, because when I tried to boot the cd in EFI mode, I have always gotten an Error anthen when I tried to Install or test Ubuntu, the Monitor just was black. I know found what i had to do, propably because i have 2 Graphics card with SLI: I had to add following Options when pressing e in the menu: