PDA

View Full Version : [SOLVED] Desktop occupies only a part of the display



sumithar
May 4th, 2014, 11:17 PM
I just installed lubuntu 14 on an old Dell Inspiron 1100 laptop with pentium 4 and 1GB RAM. Installation seemed to go thru fine but when I boot into Lubuntu I find that the desktop occupies only about a quarter of the screen, the top left quadrant as it were. Which pretty much renders it useless at this point!

Any ideas are welcome.

mrgs
May 4th, 2014, 11:27 PM
Please run
lspci -k | grep -A3 VGA and post the results in CODE tags.

sumithar
May 5th, 2014, 12:56 AM
Inspiron-1100:~$ lspci -k | grep -A3 VGA
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
Subsystem: Dell Device 0149
Kernel driver in use: i915
00:1d.0 USB controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 02)

Is this what you wanted?
Thanks

ibjsb4
May 5th, 2014, 01:20 AM
If I read that right, its good. Could you post the output of:


xrandr

sumithar
May 5th, 2014, 03:40 AM
Inspiron-1100:~$ xrandr
Screen 0: minimum 320 x 200, current 640 x 480, maximum 32767 x 32767
LVDS1 connected 640x480+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
640x480 60.0*+ 59.9
VGA1 unknown connection (normal left inverted right x axis y axis)
1360x768 59.8
1152x864 60.0
1024x768 60.0
800x600 60.3
640x480 59.9
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Hi,
Hope that tells you something!
Thanks!

Luke M
May 5th, 2014, 12:45 PM
The problem is that linux thinks your screen is 640x480. You have to create an xorg.conf file with additional resolutions.

Suggest googling "Dell Inspiron 1100 xorg.conf" and see what you can find.

mrgs
May 5th, 2014, 01:39 PM
http://superuser.com/questions/347131/xrandr-shows-two-displays-lvds1-but-how-can-i-use-vga1-only

sumithar
May 6th, 2014, 01:54 PM
Thank you mrgs and Luke M and ibjsb4.
I found some instructions to tweak grub to add modeset and tried that. But apart from now displaying the same small sized desktop in the middle of my display (as opposed to the the top left quadrant) it didn't do anything.
I also followed the instructions on the superuser page but that gave me an error message.

At this time it's not worth my time to pursue this exercise any further. I guess I'll just have to take that laptop to my local electronics recycling place :-(

Not that it matters, but I also tried to install Mint and Xubuntu. The former just kept clocking and the latter complained with an illegal video mode, so Lubuntu was the only one that actually installed! I wish the laptop had a DVD drive, my options would have increased a bit, I could have given my tried and trusted Fuduntu a go- I only have that on DVD.

mrgs
May 6th, 2014, 02:27 PM
It's a long shot, but you could try to add an xorg.conf as described in the link in my signature.

ibjsb4
May 6th, 2014, 02:31 PM
It's a long shot, but you could try to add an xorg.conf as described in the link in my signature.

Is Bodhi an option?

mrgs
May 6th, 2014, 05:03 PM
Asking me? Yes, it's worth a try, especially the 2.4 version.

sumithar
May 7th, 2014, 02:28 AM
I created /etc/X11/xorg.conf as follows


Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "AccelMethod" "uxa"
EndSection

But it didn't make any difference.

sumithar
May 7th, 2014, 02:31 AM
I was holding off on trying bodhi cos I read some reports about its being quirky.

I can give it a shot. The process looks rather roundabout, they assume that I am doing it from an existing Linux system and wants me to create a bootable USB drive and so on.
I will see if I can just bung in the CD with the ISO image and see how far it takes me.

Luke M
May 7th, 2014, 08:45 AM
Try this /etc/X11/xorg.conf:



Section "Monitor"
Identifier "Internal monitor"
Option "DPMS"
HorizSync 28-80
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Internal monitor"
DefaultDepth 24
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection


After rebooting see if you can select 1024x768 as a resolution.

sumithar
May 7th, 2014, 01:45 PM
Hi Luke,
I tried your xorg.conf and rebooted but made no difference.
I don't see 1024x768 as an option when I got into preferences/Monitor. that command xrandr now shows a different result


Inspiron-1100:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
640x480 73.0*

Luke M
May 7th, 2014, 05:57 PM
Ok, that didn't work. Sorry. Game for another? try editing /etc/default/grub,

GRUB_CMDLINE_LINUX="vga=792"

then run
sudo update-grub

(actually it would be easier to test by using the "e" option of grub, if you know how to do that. Hit "e" and add vga=792 to the end of the linux line...it won't be permenanently saved, but that's fine for testing)

sumithar
May 8th, 2014, 01:15 AM
When you are willing to take the time to provide me alternatives, it would be dreadfully churlish on my part to not try them out, wouldn't it? Anyway, that last suggestion of yours did work and I have a lovely desktop that fills up the whole screen. Thank you, danke, merci, gracias, dhanyavaad- you get the picture