View Full Version : [SOLVED] UEFI problems with Aspire v3-772g with 14.04

May 3rd, 2014, 01:29 PM
Has pre-installed windows 8.1
Installed Ubuntu 14.04 as secondary OS, ran boot repair, but still cannot boot into ubuntu. Switched off fast-boot and secure boot but still no luck.

Here is the boot-repair log: http://paste.ubuntu.com/7386007

Mounted efi partition in windows and /ubuntu directory had no .efi files, just some files named with gibberish symbols.

Everytime boots directly to windows. Any ideas?

May 3rd, 2014, 04:06 PM
The files on the EFI partition in /EFI/ubuntu should just be normal files like grubx64.efi, grub.cfg, ...etc. Sounds like bug 1090829, where the /EFI/ubuntu directory is corrupted. If you can delete the files, just reinstall grub-efi, if not, try the dosfsck mentioned in comment 40 of the bug to eventually remove the whole directory.

May 3rd, 2014, 08:51 PM
This user had a Aspire v5.

Did you go into UEFI and change to boot ubuntu entry in UEFI menu.
See last steps that user posted.

May 5th, 2014, 06:56 AM
Found the problem, EFI disk was corrupted. Used chkdsk to fix it and then was able to delete the ubuntu directory on efi drive. Then used boot-repair once more and new .efi files were correctly installed.