View Full Version : [ubuntu] Unity not loading

April 29th, 2014, 12:27 PM
All of a sudden, when I log in to Ubuntu 14.04, I have no top menu bar, no launcher, no dash, only my desktop. Logging in as guest works fine.

Don't know if it's relevant, but if I log in as guest, do ctrl-alt-F1 to open a terminal, log in as my user, run startx to open another gui session, and then try starting Unity from the terminal, it says “Invalid MIT-MAGIC-COOKIE”.

Also, ~/.xsession-errors has a lot of error like this:

AccountsService-WARNING **: SetInputSources call failed: GDBus.Error: org.freedesktop.Accounts,Error.PermissionDenied: Not Authorized

What else can I do to troubleshoot?

EDIT: This is what solved it, but only for the current session:

sudo apt-get install unity-tweak-tool
export DISPLAY=:0
unity-tweak-tool --reset-unity

Doing this after every reboot now gives me Unity, except for the top menu bar

April 29th, 2014, 01:03 PM
this happens sometimes when the .Xauthority file is corrupted. It's a hidden file in your uses dirctory.

try boot to a teminal and deleting it. cd to the home folder
cd /home/<yourusername> then
sudo rm .Xauthority
Then reboot. it will be regenerated on login.

April 29th, 2014, 01:13 PM
Thanks, I should have mentioned that I tried that, but with no effect.

April 29th, 2014, 01:22 PM
have you checked the permissions on your home directory? use
ls -l to see the permissions.

April 29th, 2014, 01:39 PM
It looks ok; I am the owner, and I can read and write: `drwxr-xr-x`

April 29th, 2014, 02:09 PM
Solved it:

Log in and open a terminal (ctrl-alt-F1). If that is not possible from your user account, do it from a guest account, and replace DISPLAY=:0 with DISPLAY=:1 below-

sudo apt-get install unity-tweak-tool
export DISPLAY=:0
unity-tweak-tool --reset-unity

April 29th, 2014, 02:31 PM
....unfortunately the above fix only worked for one session. Still at the same spot as I was this morning... :-/

April 30th, 2014, 12:24 PM
I followed the steps contained within the top answer at http://askubuntu.com/questions/17381/unity-doesnt-load-no-launcher-no-dash-appears

Compiz config manager will prompt you with a few more plugins that will need to enabled.

Unity has loaded okay for me after the reboot step.

Hope this works for you!