PDA

View Full Version : [SOLVED] Trying to return to default Ubuntu login page after uninstalling Lubuntu desktop.



Bill Grabowski
April 26th, 2014, 05:23 PM
I successfully installed Ubuntu 14.04 64bit, and wanted to try the Lubuntu desktop as an alternate. I tried Lubuntu desktop, then uninstalled it, but now when I log out or reboot, instead of getting the default Ubuntu login page, I get a version of the Lubuntu login page, which I don't prefer. I have tried to remove all vestiges of Lubuntu using the Software Updater and Synaptic package manager, but this does not solve the problem. Short of reinstalling Ubuntu, what can I do?

Bill :(

deadflowr
April 26th, 2014, 06:28 PM
Try this

sudo dpkg-reconfigure lightdm
at the page select lightdm and then ok.
Reboot.

Bill Grabowski
April 26th, 2014, 06:44 PM
deadflowr,

Tried sudo dpkg-reconfigure lightdm but did not get a page or option to select lightdm. After reboot, still had odd login screen.

Bill

deadflowr
April 26th, 2014, 07:32 PM
By login page, do you mean the page you enter your password, or the page the comes up as it's booting?

Bill Grabowski
April 26th, 2014, 08:30 PM
The page where I enter my password.

deadflowr
April 26th, 2014, 08:38 PM
I wonder if you need to reinstall lightdm and unity-greeter.
Just a thought.

Don't know if this help but it might
http://askubuntu.com/questions/371742/how-to-restore-ubuntu-login-screen-after-lubuntu-install

Bill Grabowski
April 26th, 2014, 09:44 PM
Your suggestion pointed me to the solution. The problem was that lightdm.conf was still giving preference to Lubuntu. There was a directory /etc/lightdm/lightdm.conf.d containing a config file for lubuntu, which I removed. So ...

sudo gedit /etc/lightdm/lightdm.conf

...then enter:

[SeatDefaults]
user-session=ubuntu
greeter-session=unity-greeter

Save, exit, and importantly ... REBOOT.

Before I did the above, I also did this ...

sudo apt-get purge lightdm
sudo apt-get install lightdm

... but I'm not sure that was really part of the solution.

Thanks for the help!!

Bill