View Full Version : [SOLVED] 13.10 to 1404 upgrade fail - keyboard configuration?

April 23rd, 2014, 10:33 PM
I am trying to upgrade an Ubuntu 13.10 machine where 13.10 was a fresh install and not an upgrade. This machine is used only for SABnzbd+, SickBeard, and CouchPotato at this time, so other than adding necessary software for those applications, no other customization has been done. But no changes have been made to this machine for months, other than the occassional updates from canonical.

This morning I tried to do the upgrade to 14.04 and I think the results are mixed. Before doing the upgrade, I checked and made sure no more updates were there for 13.10 using the software updater. Then ran the upgrade. Quite some time into the upgrade, after everything was downloaded and the upgrades were actually being installed, there was a dialog box that came up saying the keyboard-configuration failed with the options to report or cancel. It didn't say much else, but at any rate I clicked on cancel. Things seemed like they were continuing so I went and did something else hoping this was a minor problem. After another bit of time, there was a dialog box that came up saying the upgrade had failed, anything that had been done would be undone, and a dpkg -a would be run. I'm sorry I don't have the exact text available anymore. When that was done, I shut down the machine and rebooted it thinking that I would take another shot at running the upgrade with no applications running. When it came back up there were several dialogs for things that had crashed. I disabled the script I had that starts SAB,SB, and CP at startup and rebooted again, and this time the system came up clean. However, there was no option in software-updater to run the upgrade again.

I looked through this forum looking for other peoples upgrade problems, but none, of course, seem to be like mine. I have tred a few things that have been suggested for other people, so here is what I have now. The first file is the output of the "lsb_release -a" and "uname -a" commands. The other is the output of the "sudo apt-get upgrade" command that was run immediately after "sudo apt-get update".

Any thoughts????



April 24th, 2014, 01:51 AM
I figured it out. I still don't understand why it happened, but I got a complete upgrade. I looked closer at the error message and saw that "libdebian-installer.so.4" was't found. I used synaptic and installed "libdebian-installer4", and when it finished the installation, all of the "X" packages that were dependant upon the keyboard-configuartion finished installing too.

I checked my other machine that I did a fresh install of 14.04 on too. This is a similar class machine and they both have nVidia graphics cards installed. This other machine does not have libdebian-installer4 installed but everything installed without a hitch.

Oh well,