PDA

View Full Version : 14.04 shutdown problem



josdb
April 22nd, 2014, 01:54 PM
I have a Dell Latitude D351 and had a shuwdown problem (it hung instead of shutting down) with Ubuntu 12.04 which disappeared somewhere in the course of upgrading to Ubuntu 13.10. Now I have upgraded to 14.04 and the same shutdown problem is back. I've heard from more people having the same problem. Any solution?

jbaerboc
April 23rd, 2014, 03:24 AM
Is there something on your screen when it hangs? For instance some text in a terminal style environment? Or does it just ignore the fact that you clicked on "shutdown" ?

josdb
April 23rd, 2014, 07:08 AM
Sometimes (seldom) there's a black screen with text, saying "Terminating all processes OK" and then it hangs. But must of the time the system hangs with the Ubuntu screen and the blinking dots, if you get what I mean. Thanks for the reply!

jbaerboc
April 23rd, 2014, 08:53 AM
Hmm what we'd need to do is force it to shutdown in verbose mode. That'll then give us more hints as to where it is hanging and what's causing it.

Tried to find a normal GUI method of shutting down in verbose mode but couldn't do so. Apprently you should be able to type in the following in a terminal to shutdown and show verbose:

sudo shutdown -v now

If this works it should shutdown but give you time to read what's going on. Keep an eye on things and if you see where it stops and hangs let us know here and maybe we can help more.

josdb
April 23rd, 2014, 09:28 AM
OK. Here's what I get:

wait-for-state stop/waiting
*Stopping rsync daemon rsync [OK]
*Asking all remaining processes to terminate... [OK]
*Killing all remaining processes... [fail]
*Deactivating swap... [OK]
*Unmounting local filesystems... [OK]
mount: / is busy
*Will now halt

And there it hangs forever...

josdb
April 23rd, 2014, 04:13 PM
The problem disappeared. It must have been solved by something I did to repare another problem. I think what it must have been was:

sudo apt-get install build-essential

But I also installed ndiswrapper. So one of those two must have done the trick.

Thanks for any feedback.

jbaerboc
April 23rd, 2014, 05:19 PM
Hmm the only way I could see ndiswrapper having to do with it is if your wireless card wasn't letting the computer turn-off [constantly trying to get itself working or something]. Otherwise I think the "build-essential" would have to do with the kernel right? If that's the case it could have solved a kernel bug. Either way glad to hear your up and running normaly!