View Full Version : 13.10 no option for "install alongside windows"7. Doesn't detect partitions either

February 20th, 2014, 06:13 AM

I am new to the Ubuntu world and I would really appreciate your help in this. I noticed quite a few posts with *similar* issues (but not quite the same) and I wasn't able to find a solution in over a day now.

What I'm trying to do:
- To install either Ubuntu 12.04.3 or Ubuntu 13.10 (tried with both, several times) alongside Windows 7, so that I can have the dual boot option menu at start
- Laptop model & specs: Lenovo N580, i3, 4.0 GB RAM, 500GB hard drive (just one partition initially, C drive but I shrinked to free up ~110 GB so far to see if Ubuntu detects it or not - it didn't)
- I don't mind having more partitions but I am not really sure how many partitions to make (guessing I should be making the partitions from Ubuntu instead of Windows).

Actions/Attempts and results so far:

1) I tried to boot the USB installer in both the UEFI mode (where you see the black grub menu option) and the non-EFI mode. Both results in the same, in the installer steps of Ubuntu. It says "No detectable operating systems" and I get no "Install alongside Windows" option (picture below). I have also tried with "Try Ubuntu" without installing, in both modes, to check out the partitions with the "GPartition Editor", only to find that the it doesn't 100 GB unallocated space and a partition - it just sees a block of 500GB unallocated space (picture below). If I choose "Something else", from the installer steps, the results are the same.

Note that in this "Try Ubuntu" mode, I can actually see the C drive mounted (which has Windows 7), with the right space (~300+GB) but the installer cannot detect it (visible in the picture). I am also pasting some command line results below, in case it helps.

2) I figured out from my Windows 7 "diskmgmt.msc" that the OS was initially installed in non-EFI mode (picture included). As suggested in the community posts, I matched it with the non-EFI mode of Ubuntu installer as well by changing the settings from the BIOS menu at startup.

3) Not sure if this is relevant or not but for both the EFI and non-EFI mode, I see this following message very briefly, before USB installer takes over (either the grub menu or the the full screen purple background image):
"Could not open "\EFI\BOOT\failback.efi":14

4) When I tried it with Ubuntu 12.04.3 USB installer at first, the results are pretty much identical but the grub version is slightly older in UEFI mode (which is why I tried it with the Ubuntu 13.10 but didn't help).

I am afraid that if I try to make a partition from Ubuntu installer (which cannot detect the allocated space correctly), I will be messing up the Windows 7 installation. Any help will be greatly appreciated.



Some command line results from the "Try Ubuntu.." mode, for partitions:
ubuntu@ubuntu:~$ sudo parted -l
Warning: /dev/sda contains GPT signatures, indicating that it has a GPT table.
However, it does not have a valid fake msdos partition table, as it should.
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT
partition tables. Or perhaps you deleted the GPT table, and are now using an
msdos partition table. Is this a GPT partition table?
Yes/No? No

Model: USB Flash Disk (scsi)
Disk /dev/sdb: 8020MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1159kB 8020MB 8018MB primary fat32 boot, lba

ubuntu@ubuntu:~$ sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x9e8f47dc

Device Boot Start End Blocks Id System
/dev/sda1 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 * 206848 756570111 378181632 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 8019 MB, 8019509248 bytes
256 heads, 44 sectors/track, 1390 cylinders, total 15663104 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdb1 * 2264 15663103 7830420 c W95 FAT32 (LBA)

February 20th, 2014, 01:42 PM
WUBI doesn't work with UEFI and has been discontinued after 12.04. If you change to non-UEFI mode, Windows must be reinstalled. https://help.ubuntu.com/community/UEFI explains.
You'll need to either dual boot or use virtualization, like virtualbox. The type of workload for the VM will determine which is the best answer.

If you don't mind, please edit the 1st post use the "code" tags around output from commands so they line up to be easy to read. I find them too difficult to read as currently posted. The "Go Advanced" button will make that easier.

fdisk is deprecated. Use parted going forward. BTW, I really think you DO have a GPT disk.

February 20th, 2014, 02:35 PM
I think you have GPT data on your disk. Since you are using Windows 7, you need to confirm that you have installed Win7 in UEFI mode.
You could be using 'msdos/MBR' partition scheme. And I think this is confusing the installer whether its a GPT or MBR disk. That is 'EFI' error.

This can be fixed with Fixparts (http://www.rodsbooks.com/fixparts/). Run it from the Ubuntu Live.

However, if you have indeed installed Win7 in UEFI mode then we will need a different approach.

Mark Phelps
February 20th, 2014, 03:34 PM
I am afraid that if I try to make a partition from Ubuntu installer (which cannot detect the allocated space correctly), I will be messing up the Windows 7If you DO end up using the installer to shrink Win7, you are indeed risking filesystem corruption.

Your better approach is to shrink the Win7 OS partition from inside Windows Disk Management --leaving the new space unallocated.

Then, you use "something else" in the installer to create the partitions for Ubuntu.

February 20th, 2014, 07:51 PM
Hi @TheFu,

Thanks for your thoughts. I actually verified that my Windows 7 was not installed in UEFI mode by using "diskmgmt.msc" from Windows. According to other threads I found, if Windows was in fact installed in EFI mode, it would be shown on my C drive partition (which it doesn't show now, as you can see on the picture). So, on that thought, it doesn't make sense for me to try to re-install Windows again. Does it? (I just disabled the UEFI mode through the BIOS options).

I will try to figure out how to use the "code" tags for command line or code output from now on (thanks for the reminder).
For both *fdisk* and *parted* tool; I'm not really sure how to use them yet but I will try to see what I can find.


February 20th, 2014, 08:14 PM
Hi @fantab,

I will definitely try to check out this *Fixparts* you linked here. Although, I don't think the Windows 7 was installed in the UEFI mode. The "diskmgmt.msc" would have shown the C drive to be installed in EFI mode, isn't it? (that's what I found out from some of the other threads regarding this issue). On that note, does *Fixparts* still make sense?

Also, by the "EFI error" that you are hinting it, is that the same issue for which I am seeing the "Could not open "\EFI\BOOT\failback.efi":14" before the USB installer of Ubuntu takes over at boot?


February 20th, 2014, 08:20 PM
Hi @Mark Phelps,

That's exactly what I was hoping to do but as I mentioned on my first post, even though I shrunk my C drive from Windows 7, leaving ~110 GB of unallocated space, the partition tool (GpartionEditor?) from the Ubuntu installer just sees an entire 500GB of unallocated space. When I do "Try Ubuntu without installing", it actually correctly identifies the ~370 GB partition drive and mounts it as a file system (which has the Windows 7 installed). But the Gpartition editor doesn't detect it. From @fantab's response in this thread, it is probably because it is being confused between a GPT or MBR disk.