PDA

View Full Version : [ubuntu] 12.04 "Could not write bytes: Broken Pipe" Error



rondamato
February 17th, 2014, 09:25 PM
In my organization we are using an automated process to install Ubuntu 12.04 as a VDI.


All was working fine until the other day when a network problem would not let the machine "reach out" to the Ubuntu repos to grab packages.


Now, when I run the automated scripts [rc.local] to build a machine I am presented with an error on the first line of the script's output: "Could not write bytes: Broken pipe."


The only thing in the script for the machine to interpret is the first line (#!/bin/bash)...we have put pauses after each action to try to troubleshoot this script. We even changed the first line to "#!/bin/sh" and the results are still the same.

We also changed our rc.local to the default (instead of the one that our installers put in automatically) and we get the same result.

Here's the basic premise--we have ruled out anything in our build, for now. This happens in a fresh install. It's the first thing that comes up in the terminal. When the machine is started the very first thing that the terminal displays is "Could not write bytes: Broken Pipe" and then continues to things like "Checking battery [OK]"
Keep in mind that this a basic 64-bit 12.04 running in QEMU. The servers are managed with Xen. This build never showed this message before...we actually did a fresh boot (ONLY 12.04) for diag purposes and, when booted, the "Could not write bytes: Broken Pipe" error comes up. Fresh build and NO "tricky" drivers or anything like that. So basically, we are running VMs with 12.04 on them--the customers are VNCing into the machines or they use MSCTSC with XRDP to connect--the "master" servers are running CentOS. The Ubuntu VDIs are served up with QEMU running on CentOS. Could it be possible that this problem is due to QEMU? These builds always worked...the ONLY thing that is different is that we are now using a different Ubuntu master .iso than before the problem popped up (was using 12.04 LTS 32-bit and am now using 12.04LTS but the 64-bit version.


Please note that the script DOES still run and the machine DOES still boot--we just cannot have this error coming up...mainly because we don't know what is causing it and are afraid that it can cause trouble down the line.


I have seen many descriptions of this error on the forums but they almost all involve dual-boot machines not booting or failed video card install attempts...this is neither.


I am including a screenshot of the script output. Remember that this error comes up BEFORE anything (except the shell choice) is interpreted.


Does anybody have any ideas that can help me? Thank you! This one has our entire organization confused. The screenshot below will show you what I see when a machine is started.

Thank you!!

250439