View Full Version : Jedi Outcast:GLW_StartOpenGL() - could not load OpenGL subsystem

July 21st, 2006, 07:02 PM
[quot]I got it to install using loki but when I go to start it I get this error.
I have a nvidia Geforce 5500 fx and I'm using xgl/compiz[/quote]

It was an xgl issue the fix was to add (-xorgAc)to your gdm.conf-custom

like this

name=Xgl server
command=/usr/bin/Xgl :0 -fullscreen -ac -xorgAc -accel glx:pbuffer -accel xv:fbo

this also you to run programs on the underlying xserver, (For ATI users that 0 should be a 1)

and then just run your game like this

for Nvidia
DSPLAY=:93 game
for ati
DISPLAY=:0 game

Okay thats all

July 22nd, 2006, 03:57 AM

July 22nd, 2006, 02:16 PM
Any idea how to get XQF to use the DISPLAY=:0 before launching ET? If I try it, it tells me it can't find the command DISPLAY=:0

July 22nd, 2006, 07:22 PM
Do have xgl running, and if so did you add the -xorgAc to gdm.conf-custom.
What video card do you have? If you have an nvidia try DISPLAY=:93.
And also put "DISPLAY=:" first

DISPLAY=:0 game
I installed xqf and I it worked with DISPLAY=:93 xqf, but From what I saw it looked like a regular app. I didn't it use so I'm not sure if it does anything else, but you should really only use the "DISPLAY=:" for runinng games

July 22nd, 2006, 08:51 PM
There is already a similar how to in the "HOWTo"s to allow you to run any app on a standard server using a "nonXgl" prefix e.g. "nonXgl ut2004"

July 23rd, 2006, 04:02 AM
yah and that nonXgl didn't work out for me very well but this post's fix worked great so...

July 23rd, 2006, 04:52 AM
There is already a similar how to in the "HOWTo"s to allow you to run any app on a standard server using a "nonXgl" prefix e.g. "nonXgl ut2004"

I didn't start this as a howto, I answered my own question.
I just edited my post to show how I fixed it, just in case someone else had a similar problem.

December 24th, 2007, 02:14 AM
Plz help me out, i really want to play star wars jedi Outcast but becoz of this error i cant. i cant seem to figure out what to do. i am at a total lose here. plz help me somebody. plz send in an ez solution which i can understand easily n work out as i am not much of a computer freak. plz help me plzzz

September 16th, 2009, 04:45 PM
Since Angel456 didn't get his/her answered, I'll ask for them:

What if you don't have a gdm.conf-custom file and what if you don't know how to use that DISPLAY= option or where to use it?

What then?