View Full Version : [SOLVED] 13.10 install on ASUS ROG G75V - no /boot

February 5th, 2014, 01:27 PM
Hello all,

I got so horribly sick and tired of windows 8 that I went for Ubuntu Gnome 13.10. When I install it everything seems to go well (5 times so far).
BIOS: Secure boot is off, UEFI and such is off, CSM is enabled (I saw that recommended)

Problem: after install there's no way I can get to Grub.

Machine: 256GB SSD and 1TB HDD, 12GB RAM. Yes, it's a monster machine.

SDA and SDB completely wiped, clean install, but booting doesn't happen. Using the USB install I can boot from first harddisk which drops me to BusyBox, and from there it's end of story. When I install on the SSD there's no /boot dir created, I checked. That's probably the problem, as there's nothing that can get to /boot/grub, but I have no clue how to fix it.

I just tried installing on the HDD but that goes nowhere either (doesn't surprise me but hey...). Is there something I need to know or do to the boot record/partition of the SSD before this works? I know that M$oft does all kind of weird things.

You can talk reasonable tech to me, my other machine runs Linux since 1999 and that runs Ubuntu 12.04 LTS, also from an SSD (flawlessly). That didn't come with any Windows b.t.w.

I hope someone can help me out because this is a very expensive laptop and it's not doing anything at the moment.

February 5th, 2014, 04:56 PM
Okay, using boot-repair and switching the boot order of the disks in the BIOS I now at least have Ubuntu running. It's a sad thing it's running from the HD though, not the SSD.
Even with boot repair and having that stick grub everywhere it's not doing a thing with the SSD.
Running fdisk on /dev/sda shows:

Disk /dev/sda: 256.1 GB, 256060514304 bytes
255 heads, 63 sectors/track, 31130 cylinders, total 500118192 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000a405f

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 499711 248832 83 Linux
/dev/sda2 501758 500117503 249807873 5 Extended
/dev/sda5 501760 500117503 249807872 8e Linux LVM

So it should have a boot option in it. I am still puzzled but glad the machine's doing something now. Help on the SSD issue is still appreciated!

February 5th, 2014, 07:45 PM
Problem seems fixed by a tip I found somewhere else.
I only had to install /boot on a HDD partition and the rest could go on the SSD.

Added: The driver for the SSD needed to be loaded from /boot, after that it was clear sailing.