View Full Version : Problems after executing instructions in Ubuntu Wiki LTSEnablementStack

February 4th, 2014, 11:39 PM
In the process of trying to get a dongle working, (see this thread (http://ubuntuforums.org/showthread.php?t=2197164)) I performed an update in accordance with the instructions in LTSEnablementStack (https://wiki.ubuntu.com/Kernel/LTSEnablementStack). This allowed me to get a Nokia CS-15 working. However, I now have some other problems. Firstly, the Network manager doesn't start when I log in. Secondly, my .profile doesn't appear to run when I log in. when I first check $PATH I get a different result to what I get when i run the .profile explicitly:

achim@achim-W840SU-Series:~$ echo $PATH
achim@achim-W840SU-Series:~$ . .profile
achim@achim-W840SU-Series:~$ echo $PATH

Thirdly, an update from the Update Manager gave me the following response:

Requires installation of untrusted packages
Listing the details showed the following:

libnautilus-extension1a linux-headers-3.11.0-15
linux-headers-3.8.0-35 linux-headers-3.8.0-35-generic
linux-image-3.11.0-15-generic linux-image-3.8.0-35-generic
There are a number of posts about similar problems. The one that seemed to be the most relevant is this one (http://ubuntuforums.org/showthread.php?t=2173022&highlight=Requires+installation+untrusted+packages ). The problem is that the solution not only involves an update, but also an upgrade. I do not want to upgrade, I want to stick with 12.04 LTS at least until the next LTS version is available or (maybe) until support for 12.04 runs out. I did the "sudo apt-get update" thing, so that might keep the Update Manager happy for a while, though looking at the output, I rather doubt it.

So 3 questions:
1. Will setting "managed = true" in NetworkManager.conf fix the problem with the network manager, so that I can again use a LAN or WLAN connection?
2. Why is my .profile not being executed?
3. Is there any way to avoid having to do manual updates, since the Update Manager won't allow the "unsecure" updates?

Additional Info:
Something I forgot to mention is that at start-up the screen displays "Waiting for network configuration". It then waits for around 2 minutes before presenting me with the log-in screen.

February 5th, 2014, 11:58 PM
Firstly, the network issue isn't as difficult as I thought... at leastnot for WLAN and Broadband. I changed the file " /etc/NetworkManager/NetworkManager.conf " so that " managed=true". The result is that sometimes networking starts after I log in and sometimes it doesn't. If it doesn't, I select System > Network and - presto! - NetworkManager starts.

Secondly, as expected the update manager made another appearance with some more updates in addition to the ones that didn't work before. Out of sheer perversity I clicked "install updates" and, surprise, it started downloading and installing all the updates without complaint. All I had done is, as mentioned previously, to enter " sudo apt-get update " on the console. Somehow this has fixed whatever was wrong.

The remaining difficulties still... well... remain. My .profile does not get run when I log in. When I start the machine, it still comes up with "wating for network configuration" and waits for at least 2 minutes.

If I solve these problems, then I'll post the answers. If anybody has a hint for me, I'd be happy to hear/read it.

February 6th, 2014, 10:38 PM
I take it back. It is now more difficult than ever to get a stable connection.

I tried creating a launcher to force the network manager to start. It contained the following command:

gksu service network-manager restart

Since using this the dongle drops out after at most 2 or 3 minutes, sometimes almost immediately. I'm going to try to post this after starting the device again, if it stays up long enough.

Can somebody PLEASE help? I'm getting desperate. Could this be a hardware problem?

Additional Info:
Almost immediately after posting the stuff above, my connection dropped out again. Reconnecting was useless, because it dropped out again after a few seconds. I'm posting this edit with my old WinXP machine. However it also drops out without warning. Maybe the dongle is kaput?

February 16th, 2014, 02:34 PM
I have come to the conclusion that my dongle is the problem (at least regarding the mobile Internet). I'm sending it back under guarantee and I'll have to buy a new one.

The dongle problem is being dealt with in another thread (http://ubuntuforums.org/showthread.php?t=2197164&page=1). The update manager problem has aparently fixed itself. That really only leaves the Network Manager issue and the fact that .profile doesn't run automatically.

The Network Manager has settled down and is behaving in a predictable fashion now. When I have a LAN connection, the NM starts immediately and the boot-up takes only a few seconds. When I don't have a LAN connection I still get the "waiting for network configuration" message and the boot-up takes 2 minutes. WHY? This surely isn't normal.

My .profile still doesn't run when I log-in. Here's the proof:

achim@achim-W840SU-Series:~$ echo $JAVA_HOME

achim@achim-W840SU-Series:~$ . .profile
achim@achim-W840SU-Series:~$ echo $JAVA_HOME

I have checked /etc/profile and /etc/profile.d/bash_completion and found nothing untoward. There are a whole mess of scripts in /etc/bash_completion.d and I don't think it would be productive to go through then 1 by 1. I can execute the .profile explicitly as seen above, but I'd be happier if it worked normally.

Any insights? Hmmm?? I don't expect answers, but a hint or two as to where I can look would be a start.

March 16th, 2014, 06:53 PM
This is probably my last post on this subject, since I've had zero response.

There are oodles of posts out there about .profile not running under various circumstances. None of them seem relevant. The things explained in those posts (ad nauseum) are all things of which I am aware:

.profile is only sourced automatically for log-in shells.
.profile is not sourced if .bash_profile or .bash_login exist

Neither of those tips get me any further... as mentioned, I knew that already.

As far as the networking problem is concerned, I take back the assertion that it works OK when the LAN cable is connected. Regardless of whether or not the macine is attached to a network or not, at log-in I get the message "waiting for network configuration". This is annoying, since the machine would otherwise boot up in about 15 seconds. As it is, I have to wait 2 minutes.

If I find a solution I'll post it... if the thread isn't closed first.

March 20th, 2014, 12:09 AM
A work-around for the networking problem can be found here (http://tech.pedersen-live.com/2012/05/disable-waiting-for-network-configuration-messages-on-ubuntu-boot/). I did this and now I get a short message saying the bootup will continue without full network configuration. This is fine by me, since it seems to make no difference whatever to the behaviour of the laptop.

There is another solution at this URL (http://virtualboximages.com/%5BSolved%5D+Waiting+for+network+configuration.+Wa iting+up+to+60+seconds+for+network+configuration). I haven't tried that one and, since the work-around seems to work, I probably won't bother.

Never-the-less it is somewhat unsatisfying to have these solutions which say: "do this... edit that... and it will all workout." It would be really nice if somebody would expain what is really going on. Like, what is this "PLYMOUTH" thing? What does it do for networking? Does anybody know where I can find out?

For the sake of completeness, my /etc/network/interfaces file looks like this:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

iface ppp0 inet ppp
provider ppp0

auto ppp0
Since that second solution recommends changing "eth0," I trien the command "ifconfig -a" to see if there wa anything amiss. here's what I got:

eth0 Link encap:Ethernet HWaddr 00:90:f5:f0:73:f5
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

eth0:avahi Link encap:Ethernet HWaddr 00:90:f5:f0:73:f5
inet addr: Bcast: Mask:

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:982 errors:0 dropped:0 overruns:0 frame:0
TX packets:982 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:85392 (85.3 KB) TX bytes:85392 (85.3 KB)

ppp0 Link encap:Point-to-Point Protocol
inet addr: P-t-P: Mask:
RX packets:10802 errors:0 dropped:0 overruns:0 frame:0
TX packets:8236 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:11667941 (11.6 MB) TX bytes:820309 (820.3 KB)

wlan0 Link encap:Ethernet HWaddr 0c:8b:fd:6c:25:be
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wwan0 Link encap:Ethernet HWaddr 0a:ef:75:5a:5d:44
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Doesn't really help, so I'm sticking with the work-around.