View Full Version : [ubuntu] Ubuntu not starting up on windows 8 with LiveUSB

February 2nd, 2014, 06:46 AM

I recently bought a new laptop, an HP Pavilion 15 sleekbook, model 15-b119wm, with Windows 8 pre-installed. I created a LiveUSB, put ubuntu 12.04.2 on it, disabled secure boot, and attempted to start up the computer through the usb. Nothing shows up - a black screen flashes for a few seconds, then nothing.

I have ubuntu on another pc alongside win7, so I'm somewhat familiar with this stuff. I had no idea that windows 8 would be so damned frustrating, and I have absolutely no idea where to go from here.

Bucky Ball
February 2nd, 2014, 07:09 AM
Boot to Windows and switch off Faststart (or whatever it's called) in the software. They don't make it easy.



... gives you some clues. It equates to Win* hibernating which will prevent ANYTHING else from functioning. ...

And BTW, welcome to the forums! ;)

February 2nd, 2014, 07:29 AM
thanks - I'm glad to be here :)

well, I did what that guide told me, and still a blank screen, except now in the bottom-left corner it says "ESC...Pause Startup"

February 2nd, 2014, 07:33 AM
HOWEVER... under System Configuration, the platform key says "Not Enrolled". Not sure if that has anything to do with it.

Basically everything else is done - faststart/secureboot off, legacy support enabled.

Under Tree
February 2nd, 2014, 07:35 AM

February 2nd, 2014, 07:36 AM
I used the ubuntu-12.04.3-desktop-amd64 iso file, and used Universal USB Installer to create my LiveUSB

EDIT: now the damned thing says "Press the ESC key for Startup Menu". Pressing ESC does nothing. Ready to start smashing things

February 2nd, 2014, 07:59 AM
ahhh, it says "The selected boot device has failed"

Bucky Ball
February 2nd, 2014, 08:02 AM
Try UNetbootin.

February 2nd, 2014, 08:06 AM
oki-doke, am trying that, will return with results.

EDIT: process paused at step 2, at 666 mb. the future does not look bright for me.

February 2nd, 2014, 08:16 AM
Did not work. Same mistake as before.

February 2nd, 2014, 06:36 PM
You probably need to turn fast boot off, and secure boot off. Then depending on which video chip you have you may need other boot parameters like nomodeset. But if Intel it is others.

With very new UEFI systems, usually better to use 13.10 or wait for the new 12.04.4 that will be out in a couple of weeks.
Shows install with screen shots for both BIOS & UEFI, so you know which you are using.
Also shows Windows 8 screens
Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot. required for UEFI & grub bug fixes

How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
BIOS screens shown
Possible boot options suggested by ubfan1
Info on other boot parameters

HP's seem not to be the easiest to get working.
HP to get into UEFI/BIOS menu - escape then f10 as soon as it starts.

acpi=off worked for HP2000
HP Envy M6
HP Envy - Legacy boot seems to mean either UEFI or Legacy depending on which is found to boot from
Installing Ubuntu on HP Envy-6 Details of what worked post #11

February 2nd, 2014, 08:25 PM
thing is, I can't even to the part where I live boot the damn thing first. I get as far as turning off secureboot and fastboot in the BIOS, prioritizing USB boot, rebooting the computer with USB stick in, then nothing.

February 2nd, 2014, 08:40 PM
Are you adding nomodeset or other boot parameters if Intel?

And the procedure to add them is different with BIOS or UEFI.
With BIOS hit any key immediately when accessiblity (tiny) icons are at bottom & then f6
With UEFI it is like first boot after install and you have to manually edit boot stanza. Use e for edit, scroll to linux line and replace quiet splash with nomodeset.

Some can only install in BIOS mode and then you have to use Boot-Repair to convert to UEFI. A few only work in BIOS mode and you then can only dual boot from UEFI menu or one time boot key.

February 2nd, 2014, 09:05 PM

I will post a detailed description of each step I took, as well as model, specs, etc. of my laptop. Thank you so much for your help, all of you - just give a sec while I finish installing it.

February 2nd, 2014, 11:45 PM
Well, I completely wiped Windows 8 (thank god), so I already forgot the specific steps needed to fix my problem.