View Full Version : [SOLVED] GRUB won't list USB boot obtion.

January 14th, 2014, 09:05 AM
So i got a Samsung NP3000C(or something like that), pre-installed with Windows 8. I want to keep it for Games, but i need Linux for work etc.
I made a boot-able Flash drive. I have followed countless tutorials on disabling FastBoot, changing UEFI settings etc. But whatever i do, i only have the "Windows boot loader" as an option in boot priority. Does anyone know how i can make my BIOS recognize my USB?

January 14th, 2014, 09:13 AM

January 14th, 2014, 05:55 PM
Is this an older Samsung with UEFI, or a year or two old?
If Samsung check model number as some can only be installed in legacy/CSM mode or computer may be bricked.
Kernel updates being released and Samsung needs to update UEFI/BIOS.

UEFI boot live-usb bricks SAMSUNG 530U3C,np700z5c laptop - fix released
The problem also appears to affect Ubuntu 12.10 and other Samsung models. The Ubuntu bug report includes posts from users reporting that the problem also affects 300E5C, NP700Z5C, NP700Z7C and NP900X4C series laptops.

Newer systems or UEFI updates seem to resolve many of those issues.

January 15th, 2014, 12:39 PM
My PC is quite new, a series 3. I will check, and follow up on your links. Thank you.

January 15th, 2014, 04:11 PM
Some other newer Samsungs

SAMSUNG Series 3 NP365E5C-XXXXX laptops
Samsung series 5 UltraBook, erase Windows & install to SSD

How to: Dual boot Windows 8 and Ubuntu 13.10 on Samsung 900X3E
Samsung Ultrabook Windows 8 & Ubuntu & recovery boot Disk view of partitions post 7

February 1st, 2014, 01:42 PM
Sorry for answering so late :/ I fixed it. Here is what i did(almost kicked myself for not doing it in the first place):
Used a Windows tool to Update BIOS. Now i could see all my USB ports, CD drive etc.
Changed boot priority to USB.
Went to boot menu with F10, booted Ubuntu.
Dual boot worked(i tried), but i deleted Windows later. Thanks for your help though :)

June 12th, 2014, 10:49 PM

I have the opposite problem. I have Ubuntu 14.04 on a Surface Pro 2. I am trying to run Gparted Live from a Live USB, but the grub doesn't show the USB. Any ideas?

Thanks in advance everybody!

June 12th, 2014, 11:07 PM
Grub won't show a LiveCD on a flash drive. You need to enter the BIOS (setup) and change the boot priority to boot from the flash drive. Different machines use different keys so watch the first screen on boot.