PDA

View Full Version : [SOLVED] 13.10 installation boots into BusyBox prompt



victorcl2
January 7th, 2014, 04:44 AM
I wanted to test out a few 13.10 distros (Ubuntu, Xubuntu, Mint: Cinnamon, Xfce, etc.); however, all the distros I have tried out boots directly into the BusyBox prompt:



BusyBox v1.20.2 (Ubuntu 1:1.20.0-8.1ubuntu1) built-in shell (ash)
Enter 'help' for a list of built-in commands

(initramfs)


I have been following this: Bug #1241589 “ubuntu 13.10 unable to boot on live usb (busy box ...” (https://bugs.launchpad.net/ubuntu/+bug/1241589) which offered a few possible fixes.

Some say that disconnecting all additional drives solves the installation problem. I have a second hard drive caddy in my laptop and really want to avoid disassembling it just to test out a few distros. Others said to zero out the hard drive using dd, but this is also something I am trying to avoid. Also, some said to recreate the live usb/cd/dvd because the distro file might have been a corrupted download. This is not the case because the live usb works perfectly on several other systems.
In fact, I have Xubuntu 13.10 installed in my laptop using the same live usb; however, the live usb only boots into the BusyBox prompt now. I was able to install it before, but not sure why it is not working anymore on this laptop. Also, I just tested out Ubuntu 12.04 and it boots in without a problem.
Could it just be 13.10? Any insight to this problem or alternate fixes is much appreciated!

Bashing-om
January 7th, 2014, 09:13 PM
victorcl2; Hi !


Shots in the dark.
How about 2 thoughts on the sloppyation.
1. What version of 12.04 did you test with ? 12.04.1 has the legacy xorg and will work fine with legacy ATI graphics cards. Not so in any later versions IF one tries to load proprietary drivers. ATI has dropped support for older ATI graphics cards.

2. In the actual installs, has grub become corrupted ? Might consider (re-)installing grub and updating grub.



my 2 cents worth

victorcl2
January 8th, 2014, 06:32 AM
I sort of found a fix for my problem. Many people said a solution to this is to disconnect any extra drives before installation. Instead, I deleted the partition from my second drive which seemed to have worked. I did not have a lot of files on there anyway, but I am pretty sure a lot of people would not want take this route.

Bashing-om
January 8th, 2014, 06:56 PM
victorcl2; Yeah !

That will teach us to pay more attention to the "fstab" control file. Certainly a misdirection for filesystems and partitions will confuse the system and force an initramfs prompt !

Please mark this thread as solved (1st post -> thread tools ) as an aid to others seeking a solution, and keep the forum tidy.

Until next time ->


happy trails to you

dennisn77-ameritech
April 12th, 2014, 05:13 PM
I have the same problem whether I use a DVD from Ubuntu User magazine, or making a USB stick install. I have two hard drives, one has Windows, the other Ubuntu.

Bashing-om
April 13th, 2014, 01:27 AM
dennisn77-ameritech; Hi !

Show us what we are working with:
from the liveDVD -> terminal:
Post back the outputs - between code tags - of terminal commands:


sudo fdisk -lu
sudo parted -l
sudo parted /dev/sdb unit s print

code tag tutorial:
http://ubuntuforums.org/showthread.php?t=2171721&p=12776168#post12776168

Maybe facing the 4 partitions (msdos) limitation ?
When we know more can tell more.



ain't nothing but a thing