PDA

View Full Version : [SOLVED] gpg: no valid OpenPGP data found



prkhr4u
December 31st, 2013, 05:42 AM
I am trying to install gstreamer-sdk for ubuntu 12.04

When i run this command:

wget -q -O - http://www.freedesktop.org/software/gstreamer-sdk/sdk.gpg | sudo apt-key add -
to install gpg keys,it gives me an error after some time:

gpg: no valid OpenPGP data found

Don't know what is GPG keys,and how to resolve this issue.

I have checked the proxy settings and both $http_proxy and $https_proxy are correctly set.

Bashing-om
January 1st, 2014, 06:48 PM
prkhr4u; Hi !

Here is one way to get the key, and the explanation of what and why:

"Authentication keys" are usually obtained from the maintainer of the software repository. The maintainer will often place a copy of the authentication key on a public key server such as www.keyserver.net, but you need the "key hash" to find it. For instance, the PPA for Mozilla Team. If you go to its web page (https://launchpad.net/~mozillateam/+archive/ppa), you'll find the text snippet "Signing key: 1024R/CE49EC21"; the latter part of this is the key hash (CE49EC21).

Once the key hash is known, the key can then be retrieved using the command:

gpg --keyserver [name of keyserver] --recv-keys [keyhash]
For instance, you could import the maintainer's authentication key, whose hash is CE49EC21, as follows:
gpg --keyserver subkeys.pgp.net --recv-keys CE49EC21
Then, add the key to Ubuntu's apt trusted keys database with the following command:
gpg --export --armor CE49EC21 | sudo apt-key add -
Note there's a dash at the end of the line.

There are other ways to authenticate, but this may be the more direct.



just try'n to help

prkhr4u
January 24th, 2014, 04:30 AM
Thank you very much for the precise and lucid explanation.
I finally got it working this way (for gstreamer sdk)
The key hash I found using

sudo apt-get update
and came out to : 1900C4BE
then I requested the key this way:

gpg --keyserver http://www.freedesktop.org/software/gstreamer-sdk/sdk.gpg --recv-keys 1900C4BE
and finally added it to Ubuntu's key database:

gpg --export --armor 1900C4BE|sudo apt-key add -

Bashing-om
January 24th, 2014, 04:35 AM
prkhr4u; You do good work !

Appreciate that you provided your solution.
It corroborates when others seek in a similar situation.


can't keep a good


operating system down