View Full Version : "Missing Operating System"

December 30th, 2013, 10:48 AM
Hi everyone. I am completely new to Ubuntu and to this forum. Happy days ahead..........I hope!

I have replaced my Sony Vaio with XP installed, Core 2 processor and 2GB RAM. I wish to try Ubuntu and have copied the iso for 13.10 amd64 to a USB stick. I have configured the BIOS to boot to USB first. My preference will be to get rid of XP and install Ubuntu as the sole OS on the machine.

When I boot I get the message "Missing Operating System" and cannot get any further.

Any advice to assist in overcoming this problem will be much appreciated.

Thanks and Happy New Year!

Frogs Hair
December 30th, 2013, 04:04 PM
Hello and Welcome

The link may be helpful . https://help.ubuntu.com/community/Installation/FromUSBStick

December 30th, 2013, 04:08 PM
How did you copy Ubuntu on you stick? There is a great tool for Windows: http://www.linuxliveusb.com/

Most laptops allow to change the boot device by pressing F12. I don't know about Sony

Bucky Ball
December 30th, 2013, 04:09 PM
It has no optical drive? Anyhow, how did you make the USB (what software, OS)? I did an install via USB a couple of weeks ago and got the same message when I used Unetbootin. When I used the default Ubuntu one, Startup disk creator??? (not running an install with it installed at the moment) the USB was picked up and installed Ubuntu fine.

Just throwing that in ...

December 30th, 2013, 04:58 PM
From personal experience, it may be that you will just have to install from a DVD. I could never install Ubuntu properly from a USB stick.


Mark Phelps
December 30th, 2013, 06:24 PM
have copied the iso for 13.10 amd64 to a USB stick.

That does not work in general. What you need to do is run an app that will make a bootable USB stick from the ISO file.

Unetbootin does that, and the Universal USB Installer (from pendrivelinux.com) also does that. I've had the best results with the latter.

December 31st, 2013, 08:40 AM
On my Dell XP laptop, I also got "Missing Operating System" error. To fix the problem, the tutorial from http://tinyurl.com/Missing-Operating-System did help me get out of problem quickly! The tool referred in the article is really powerful!

January 1st, 2014, 05:08 AM
Many thanks to all who have responded here. I am grateful for the good tips and information. However, after many hours of trying, I have given up for now. Using the software suggested, I just can't get my machine to boot to USB (the BIOS is configured to do this) and each time I try, it seems to ignore the USB and goes straight to Windows in the usual way. With the aid of LiLi I did manage to run Ubuntu within the Windows environment, albeit dead slow.

I then tried to install in that mode, but the software informed me there is not enough disk space (which there is) and in any event, any actions I can perform are far too slow to make it worth the effort.

Perhaps I should try to connect my old target machine to my new machine and run setup from there, using a DVD? Not sure how to do that, but I believe it can be done using a special cable.

Regards to all.

Bucky Ball
January 2nd, 2014, 01:06 AM
You might want to try creating the USB with different software. As mentioned, that worked for me.