View Full Version : upgrade from 13.04 to 13.10 didn't complete now won't boot

December 20th, 2013, 10:46 PM
Trying to upgrade from 13.04 to 13.10 it didn,t complete. Now pc boots to root command. What can I input to restore?

December 20th, 2013, 11:18 PM
julchad46; Hi !

Ouch, Try:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get update
sudo apt-get dist-upgrade

maybe yes,

maybe not so yes

December 21st, 2013, 12:51 AM
Tried all options. Last line
Dpkg was interrupted, you must manually run ' sudo dpkg --configure a' to correct the problem. When I put this in it comes up with ' dpkg: error: unable to access dpkg status area: Read only file system' Any suggestions what should do now?

December 21st, 2013, 01:19 AM
julchad46; Hey.

" error: unable to access dpkg status area: Read only file system'" ; Puts me in mind that you are booting through the recovery console to a root login.
If this is so .. then the file system is not at that time mounted read/write. To remount the file system read/write :

mount -o remount,rw /

And try my last command sequence once more and see what results.

There is hope to (re)build the file system yet.

try try again

December 21st, 2013, 10:17 AM
It was indeed the case entered you suggested command and it then put into state where it would carry out suggested command sequence. It has now brought me back to a root comand . What next?

December 21st, 2013, 10:39 AM
ignore my last sentance in last post. Just rebooted and the system started up OK. Thanks for your clear help Bashing-Om. Much appreciated.

December 21st, 2013, 09:59 PM
julchad46; Great !

Glad to be of some small assistance.
Please mark this thread as solved, aids others seeking a solution, and helps keep the forum tidy.

This is open source at it's best ->

all of one and 1 for all