View Full Version : [ubuntu] Ubuntu does not boot without "nomodeset" in grub

December 18th, 2013, 05:26 PM
I was having a working 12.04 64bit system. However suddenly after couple of abnormal shut down of system. I am not able to boot normally.
Machine boots but there is default purple/black screen. No textbox or login buttons.
After editing the grub and making "nomodeset", machine boots.
However I can see an "AMD Testing use only. Unsupported Hardware" watermark at right bottom corner of screen.
I have not activated "ATI/AMD proprietary FGLRX graphics drivers"

Following some forums, I tried to edit grub and make it nomodeset and then tried update-grub but it fails.
I keep getting "/usr/sbin/grub-mkconfig: 36: /etc/default/grub: Syntax error: EOF in backquote substitution" error message.

Also tried to use Boot Repair but still not able to fix it.

Attaching the grub file for reference (grub.txt).

December 18th, 2013, 05:38 PM
While booting i can see following entry:
linux /vmlinuz ........ ro drm.\ debug=0xe plymouth:debug

December 18th, 2013, 06:29 PM
Silly computers do not like typos. And often those are the hardest to find.

quite splash nomodeset

quiet splash nomodeset

January 3rd, 2014, 10:01 AM
Thanks for pointing out.
I was not able to fix it any which way so I just reinstalled it and it worked.

January 3rd, 2014, 10:18 AM
FYI your GRUB_CMDLINE_LINUX_DEFAULT line also had a Unicode double quote instead of a regular ASCII character

GRUB_CMDLINE_LINUX_DEFAULT=”quite splash nomodeset"