PDA

View Full Version : [SOLVED] Cryptswap1.. (endless failure)



weber-h3x
December 13th, 2013, 05:35 AM
yep.... i know it has been posted about 398475032 times everywhere else, but i CANNOT seem to solve this...

I recently had my Ubuntu 12.04.3 system crash & then when re-installing, it says cryptswap and swap setup just fine, but once the system tries to load, i get the message above.
I scoured the web high and low, trying everything from terminal commands, to GParted, to punching kittens... nothing seems to work.
3 pots of coffee and a whole day later, i find this:

http://askubuntu.com/questions/341979/what-to-do-about-the-disk-drive-for-dev-mapper-cryptswap1-is-not-ready-yet-or

I tried that, and everything went well... then upon reboot, it still gives me the same god-forsaken message!
...then G parted says the swap area is broken... again...

WHAT IN THE F**K!??!

-------------------

As for a solution, I've seen a few suggestions of people saying, "DO NOT encrypt your home folder" and everything will be fine...

.... I don't know what to do... aside from pull my hair out and drink more coffee...

weber-h3x
December 13th, 2013, 05:40 AM
Specs:

Ubuntu 12.04.3 (64 bit)
4096 linux-swap (primary)
remaining area = ext4 (primary)

AMD quad-core
8g dual-chan memory
two 8800-gts-512 (SLI)
160g HDD (main)
320g HDD (backup)

PaulBx
December 14th, 2013, 07:21 AM
Do you really need swap? Try swapoff -a. Buy some more memory.

weber-h3x
December 15th, 2013, 03:13 AM
Re-install >

4096 swap (beginning + primary)
remaining /ext4 (beginning + primary)

DO NOT Encrypt /home
DO NOT update during install

complete install > add indexes > update system > set drivers > profit