View Full Version : [ubuntu] Dell XPS 15 Haswell Windows 8.1, Ubuntu Installation Hangs

November 13th, 2013, 10:01 PM
Just got my Dell XPS15 (Haswell) with Windows 8.1. Been a Mac user for a few years now but the price point of the new Dell convinced me to switch back and try dual boot with Ubuntu. After I shrink the partition and reboot with Ubuntu 13.10 on USB - the installation procedure fails on selecting a partition/hard drive. Booting with legacy mode.

Anybody have insight on what to do?


November 13th, 2013, 10:23 PM
What video and is this an Ultrabook?

Some other Dell threads. Models seem similar but options make a difference.
Dell 14z & 17r with Intel SRT
Dell UltraBook - Instructions & Details in Post #15 & 16 Devine Shine
Installing Ubuntu 12.10 x64 on Dell XPS 13 Alongside Windows from USB New user with Details post 10
Dell Inspiron 17R SE - 12.04.2 but otherwise similar to XPS13 above
Dell XPS 14 Ultrabook what works
Dell 14z used Dell Recovery and Refind

These were not Dell but were Haswell, so some settings may apply.
Toshiba Satellite P50 model number: P50-A-01E Haswell processor
Turned NIC (Integrated Network Interface Controller) off and then booted off of USB. Was NOT an issue with any Linux distro just a quirk of the laptop.
Am now running 13.10 daily and everything works. Also had to stick with EFI boot ON, Secure Boot disabled. Wouldn't boot off of any media or HDD when mode set to CSM.
Toshiba Satellite P75 intel hd 4600 needed acpi_osi=Linux acpi_backlight=vendor

November 13th, 2013, 10:40 PM
I've done a search on the forums and none of the issues describe what I encounter (afaik).

XPS 15 w/Haswell
4th Generation Intel(R) Core(TM) i7-4702HQ processor (6M Cache, up to 3.20 GHz)
1TB 5400 rpm SATA Hard Drive + 32GB mSATA Solid State Drive
Intel Dual Band Wireless-AC 7260 + Bluetooth 4.0

Like my previous post, I can start the installation process and even connect to wireless. But once I get to selecting a partition and click on "change" the system freezes.
Tried it without connecting to wireless, same result.

Not quite sure what to try next.

November 13th, 2013, 11:12 PM
With the separate 32GB SSD that will be an Ultrabook which adds complications over the standard UEFI install. You usuallly have to remove the RAID meta-data from both drives to get grub to install correctly. Also you have dual video so if in nVidia mode you need nomodeset or if in Intel mode you need Intel boot paramaters to boot.

Be sure Secure boot is off. Fast boot must be off, Intel SRT must be off and meta-data removed from drive.

After turning Intel SRT off, from terminal on live installer.
sudo dmraid -E -r /dev/sda
sudo dmraid -E -r /dev/sdb

Review other Ultrabook installs. Some that are primarily Windows users turn Intel SRT back on. Others install Ubuntu's / (root) to SSD to make Ubuntu fast, and a few have found with larger SSDs like yours they can do both as Intel SRT does not seem to use the entire 32GB.

Intel Smart Response Technology
Some general info in post #3

Some info on re-instating details in post #9 Dell 14z
Ubuntu on hard drive, re-enable SRT post #19 details

Disable the RAID, it was using the Intel rapid management thingy and telling it to disable the acceleration or the use of the SSD. If you have a different system, just disable the RAID system then install Ubuntu. Once installed you can then re-enable it.
sudo dmraid -E -r /dev/sda
sudo dmraid -E -r /dev/sdb

You will need to use the dmraid command prior to running the Ubuntu Installer so that it will be able to see the partitions on the drive because otherwise with the raid metadata in place it will see the drive as part of a raid set and ignore its partitions.

December 13th, 2013, 08:01 AM
Tom, did those directions ultimately work for you? Have you gotten all of your drivers installed? I have the same laptop as you, and am looking to make the leap to Ubuntu.

December 13th, 2013, 04:02 PM
Another link. This by Dell Tech Center.

Ubuntu on the Precision M3800 or XPS15 Nov 2013