View Full Version : [SOLVED] Upgraded to Saucy, now cannot start GUI interface

October 29th, 2013, 08:50 PM

I recently performed an inline upgrade from 13.04 to 13.10. My Ubuntu desktop is one I built a couple of years ago. Usually that spells "sketchiness", but this computer has been running the last 3-4 Ubuntu releases with no major issues for some time.

Anyway, I have an NVIDIA GeForce 8400 GS Rev 3 video card, as verified by the output of lspci -vnn |grep VGA. According to NVIDIA and to various Ubuntu PPA documents, that means I can run the NVIDIA 319 (stable) or 331 (beta) driver sets. However, I can't get either of these to work. I've also tried to install nvidia-current but that is showing me no love. Right this second, the output of dpkg -i |grep -i nvidia confirms that I only have the 331 driver installed and enabled.

So my X server does start, but it seems to hang and stays on a black blank screen. Can someone recommend some next steps?

To clarify, when my system boots, I see the following:

1. POST/Grub, no problem
2. Grey screen that says "Ubuntu GNOME" and three dots underneath
3. Black screen
4. NVIDIA Graphics logo (this screen is full color, 24-bit, 1650x1080 so I know that my PCI graphics card is working correctly)
5. Black screen
6. Boot activity showing services and daemons starting
7. Black screen
8. Graphical X interface showing an error message with no Window borders "The system is running in low-graphics mode", then etc. etc.

I can then click OK and I get back to step 6 above, which seems frozen. From there, I can Cntrl-Alt-F1 to get to a text only login screen. Help?

Note: I have also tried installing the package xserver-xorg-video-nouveau, and when I do that I have the same problem but my tty1 session has a higher resolution...
Note: I also attempted to purge and reinstall lightdm and ubuntu-desktop packages. Still no luck.

October 29th, 2013, 09:10 PM
If you have backup, return to 13.04, with end of life is January 2014. So you have a couple of months to go, when you can test if there will be a working driver in 13.10 and also test 12.04 LTS which will be supported until April 2017.

You can test the built-in driver (nouveau) and proprietary drivers in a second drive (USB, SATA, eSATA) whatever is available.

October 29th, 2013, 10:17 PM
Thanks for your reply, sudodus, but I do not have that kind of backup in place. Yeah, I know, shame on me, but I've never had a display problem this serious with any Ubuntu release.

October 29th, 2013, 11:59 PM
Have you tried the built-in driver (nouveau) yet. It works quite well with my nvidia cards (of different age) for basic graphics. But there is no 3D and no VDPAU.

October 30th, 2013, 02:26 PM
Yes, I did try that and still no luck.

October 30th, 2013, 03:41 PM
Have you tried with nomodeset and several other boot options (you can have more than one at the same time)? See these links



October 30th, 2013, 06:21 PM
Truthfully, I was hoping to avoid messing with grub if possible. But after reading the articles you shared, I gave it a shot. I added the following lines to my boot statement, but none of these have worked. I get some different results, but essentially I get back to the same black screen:

nomodeset $vt_handoff

Perhaps I don't have the combination of tricks right? The above grub commands were added while I was using the nvidia-304 driver. Let me go back to nouveau, and I'll try that with the grub commands, and if that doesn't work I'll try them with nvidia-319 or nvidia-331 (beta).

To be continued...

October 30th, 2013, 06:24 PM
Good luck :-)

November 3rd, 2013, 10:57 PM
Well, I'm sorry to report that I tried every combination of default, binary, external, and experimental video display driver I could verify works with my NVIDIA card, each with multiple combinations of refresh rates and resolutions -- all with absoluely no luck. I got varying results but none allowed me to launch the Unity or Gnome 3 interfaces.

So, I decided to get crazy and reinstall Ubuntu 13.10 after backing up my home directory (and other critical files). I decided to not keep any of my dot files or evnrinmental/shell variables and start over clean.

I am up and running 13.10 and Unity now; I ended up with the xserver-xorg-video-nouveau (1:1.0.9-2ubuntu1) driver on my system and nothing proprietary. I still don't know what happened, but thanks to sudodus for attempting to help me. ;)

November 4th, 2013, 09:26 AM
Congratulations :-)

You did the right thing. Sometimes some inherited setting (in /etc or a dot file in the home directory) from the previous version will destroy it.