View Full Version : [SOLVED] Samsung CLP-315 Won't Print After Upgrade to Saucy Salamander

October 29th, 2013, 03:11 PM
My printer worked fine before the upgrade to Saucy Salamander, and I can print a test page by going to the web interface to the printer (bypassing the driver). Printing a test page from the printers icon/UI does not work, nor does printing in any other way.

The printer is a Samsung CLP-315 installed as a network printer -- Samsung CLP-310 series using Samsung CLP-315 Foomatic/foo2qpdl (recommended). The wizard can find it, just not print from it. (Possibly irrelevant detail -- the printer was on a different IP than stored, but updating the address didn't fix the problem. HTTP to that address does find the printer.)

I've read that network printing changed with the upgrade.

Update: Before posting, I tried deleting and reinstalling the printer. I can print from it now, but when I try to print, I now have a bunch more printers that I don't have configured via the UI -- including another version of this printer with a housemate's comical nickname for it.

So, I fixed it before posting, but two things:
1) Just wanted a searchable record of this, since I failed to find a relevant thread on search.
2) How does the new print system work? Why can I see my housemate's configuration for the printer when I print, but not in the CUS printer configuration tool and status applet?