View Full Version : [SOLVED] No grub after 13.10 install

October 20th, 2013, 01:38 PM
Just installed Ubuntu 13.10 alongside Windows 8 but upon reboot there's no grub? It boots directly into Windows 8. Any help would be appreciated.

October 20th, 2013, 01:55 PM
In machines with pre-installed Windows8 you mostly have UEFI boot. Does you machine boot in UEFI?

Try Boot-Repair (https://help.ubuntu.com/community/Boot-Repair#A2nd_option_:_install_Boot-Repair_in_Ubuntu) utility. It can fix most of the boot issues. Most of the times 'Recommend Repair' is enough. Perform Boot-Repair from a Live Ubuntu DVD/USB.

October 20th, 2013, 03:50 PM
I did try the Boot-Repair but it din't work either, it did mention something about the PC booting in legacy mode instead of uefi?

October 20th, 2013, 04:03 PM
So, when running Boot-Repair this comes up

"The boot of your PC is in Legacy mode. You may want to retry after changing it to EFI mode.
Do you want to continue?"

October 20th, 2013, 04:21 PM
Fixed title.

You need to run Boot-Repair in UEFI mode, or reinstall in UEFI mode. From UEFI you should have two boot choices, one UEFI and the other BIOS/CSM/Legacy, but not always clearly labelled in UEFI menu.

October 20th, 2013, 05:36 PM
How do I run boot-repair or ubuntu installation in uefi mode?

October 20th, 2013, 05:46 PM
You have to boot Ubuntu Live DVD/USB in UEFI mode... When Selecting your boot device to boot from choose the DVD/USB in UEFI or EFI. If you boot Ubuntu in EFI mode you will see a black background with options. You see regular ubuntu background if you boot in legacy mode.

October 21st, 2013, 12:29 PM
Thank you! Got it working now.

October 21st, 2013, 12:36 PM
I'm glad its working. Mark the thread as 'solve' using 'Thread Tools'.