View Full Version : [SOLVED] touchpad doesn't work after upgrading from 13.04 to 13.10

October 19th, 2013, 08:33 AM
Dear members,

I upgraded from 13.04 into 13.10.
The touchpad on my laptop doesn't work since the upgrade.
Connecting an external USB mouse works fine.
I've tried to define settings for touchpad on system settings--->mouse & touchpad, but this is not possible.

Do you have a solution?


October 19th, 2013, 08:44 AM
That is not enough information to solve your problem. What laptop is it? Have you done anything that might have caused this? Did the upgrade went fine with no errors?

October 19th, 2013, 09:14 AM
I've just solved it.
The default definitions had to be changed.

October 28th, 2013, 06:18 AM
I've just solved it.
The default definitions had to be changed.

Hi man, can you explain what you did to fix it please? I'm having the same issue.
Its a Toshiba E45t-A4200
For what I can tell it has an elantech v8 touchpad
In 13.04 worked just like a simple mouse, no multi-touch, after upgrading to 13.10 it doesn't work at all.

xinput list shows:
PS/2 Elantech Touchpad id=12

xinput --test 12 Doesn't show any output at all

November 7th, 2013, 02:26 AM
This is happening to me on my Sony Vaio S15 as well. If I login with Gnome 3 it works fine, but with Unity no trackpad.

November 7th, 2013, 07:10 AM
strange. this happens if i "switch users" and login as another user on this machine. it's like the old user session has a lock on the mouse. If I run this it can grab the mouse for the new session, but switching back to the first session again has no mouse:

sudo modprobe -r psmouse ; sudo modprobe psmouse