View Full Version : [SOLVED] I tried to upgrade from 13.04 to 13.10 and get this error:

October 19th, 2013, 07:11 AM
Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

October 19th, 2013, 08:14 AM
Is this from the do-release-upgrade command?

Try running the software updater.
Let the updater update the system as normal, and when it finishes the normal updates it will have an upgrade button and ask if you want to upgrade to a newer version.

If you have PPAs installed the method through the software updater should disable the PPAs, which will make the update run properly.

Johan De Cauwer
October 19th, 2013, 08:42 AM
Did you read the sticky thread about 'tried to upgrade'? I won't repeat it here, it's too long but one general truth is that a clean install is always the best...

October 19th, 2013, 09:03 AM
It's from the normal "Software Updater" program. Says "The software on this computer is up to date. However 13.10 is now avalible. (You have 13.04). Then I get the 'Could not calculate' error after when in "Setting up ne software channles"

EDIT: I also have all PPA disabled.

October 19th, 2013, 09:28 AM
ran this command "sudo apt-get remove xserver-xorg-video-*" and it seems to be updating now... Will report back no matter what.

October 19th, 2013, 09:34 AM
Looks like that did the trick... still upgrading so will see how it goes after reboot. Thanks for replays and views