View Full Version : [SOLVED] Upgrading 13.04 to 13.10 Kernel panic

October 18th, 2013, 07:27 PM
During an upgrade from 13.04 to 13.10 I got: Kernel panic-not syncing: VFS: unable to mount root fs on unknown block(0,0). I manually switched off the power of my laptop. Since then I'm not able to boot Ubuntu - this error appears every time I boot.

I've been using e4rat instead of ureadahead before upgrading.

October 18th, 2013, 10:11 PM
All right, I've managed to solve my problem with a great help from rafalcieslak.

The situation: Kernel panic during upgrade from Ubuntu 13.04 to 13.10 (described above).

What to do:
At first to boot to system I needed to follow http://askubuntu.com/questions/41930/kernel-panic-not-syncing-vfs-unable-to-mount-root-fs-on-unknown-block0-0

Start with a livecd, open a a terminal
sudo fdisk -l
sudo mount /dev/sdax /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /dev/pts /mnt/dev/pts
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt
and now you can make update-initramfs and update-grub without errors
update-initramfs -u -k 2.6.38-8-generic (or your version)
And reboot your system
This allowed me to boot Ubuntu.

Then I happened to have a problem with sudo apt-get something. I was shown a message: "E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem."I run suggested command and got kernel panic as before.
I booted Ubuntu with "--no-log" parameter in GRUB's entry (because https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/1120660). This let me reconfigure dpkg with proposed command: "dpkg --configure -a" without kernel panic, finally.

The last thing to do was:

sudo apt-get update

sudo apt-get dist-upgrade

That's it.