PDA

View Full Version : [xubuntu] Xubuntu fresh install gives wrong Grub label



madtom1999
October 9th, 2013, 09:29 AM
Just installed 13.04 64 bit alongside a whole bunch of others and the Grub label for it is "ubuntu" which is not quite right.

oldfred
October 9th, 2013, 04:36 PM
It is Ubuntu and grub does not really know what desktop you are using.

I turn off os-prober and add my own boot stanzas to 40_custom. Then I can label them any way I want.

Copy the entries from this:
sudo cp -a /boot/grub/grub.cfg /boot/grub/grub.cfg.backup
gedit /boot/grub/grub.cfg
Copy them to and edit to have only entries you want:
gksudo gedit /etc/grub.d/40_custom
Then do:
sudo update-grub

IF new entries work ok, you can turn off os-prober.

In /etc/default/grub I added this:
gksudo gedit /etc/default/grub
GRUB_DISABLE_OS_PROBER=true
or turn off executeable bit
sudo chmod a-x /etc/grub.d/30_os-prober
sudo update-grub

You can also use some gui tools like grub customizer, but it seems to create a lot of extra grub files in the scripts.

New Grub Customizer works with 12.10
http://www.webupd8.org/2012/09/grub-customizer-30-released.html


How to: Create a Customized GRUB2 Screen that is Maintenance Free.- Cavsfan
https://help.ubuntu.com/community/MaintenanceFreeCustomGrub2Screen
http://ubuntuforums.org/showthread.php?t=2076205

madtom1999
November 28th, 2013, 05:08 PM
All other intallations seem to know which release/version they are installing and update grub accordingly.